2.5 TDI Strong Knock, No start

JorKSX

Registered User
So yesterday my 1998 a6 2.5tdi v6 started littleknock, When driving faster the engine like "yelled" (no fault codes)
Today morning the engine was knocking very strongly. I HAD to drive it to work (5km). After work I started the car and the knocking was very bad. I went to some car shop and bought RVS D6, new oil filter and new oil. Went to home and changed oil. After the oil change the car did not want to start. The knocking sound is like someone hits engine with metal pipe. It does not sound like valve knocking, its very strong, engine runs very badly and the whole engine shakes. After the oil change it started blinking that "glow" light. I stopped the car and checked with vcds whats wrong.
It showed me this:

Address 01: Engine
Controller: 4B0 907 401 P2u
Component: 2.5l/4VT EDC G200AG D60
Coding: 01001
Shop #: WSC 00012
2 Faults Found:
01126 - Engine Speed Signal
16-10 - Signal Outside Specifications - Intermittent
00513 - Shareware Version. To Decode all DTCs
27-00 - Please Regi
Master/Activate
Readiness: N/A

I checked the engine speed sensor and cleaned it. Now there is no fault codes. And engine is not starting. I did not remove any wires or anything. I checked every wire, everything seems to be fine. When I try to start car, someone starts hitting my car with that metal pipe again. It does not even try to start.

I know the 2.5 tdi v6 is very bad engine but I love the car, its very good like outside. Thers no rust and I keep very good care of it.
Also I know also how to fix almost everything about the car, but not engine. And this audi is my first german car so I dont know its engine yet, I have no idea what I do now or what I do next. Also sorry for bad english.
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
Service history? Timing belt? I'm no expert on the 2.5 v6 tdi but is it an engine issue or flywheel and starter issue?
 

JorKSX

Registered User
Service history is good. Timing seems to be ok. I dont kbow what the issue is. It sounds like engine problem. Because when I get the engine running. It literally sounds like someone hits engine with metal pipe and hard. And 20 times in one seccond...
 

myth

Registered User
If your engine speed sensor is faulty, the engine won't start. Check the wiring and if it's ok, change the sensor.
 

JorKSX

Registered User
But why is it knocking so strongly when I try to start? Sound like piston is hitting oil pan
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
01126 code Sometimes it tells you that the engine is out of timing. Check the timing belts!
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
I once had an injector unseat and the engine sounded awful, like it had thrown a rod. Maybe it's a fuel pump issue. That fella that tunes them might know what it is. Can't remember his user name.

Adamss24.
 

JorKSX

Registered User
I Have hand pump so I can pump disel. And when I pump the disel comes out of the pump. When i try to start engine it spits disel out. So engine gets disel. I dont really care about the No start issue right now. I want to kow what is that metal sound when starting. Someone said that piston might be broken? If I remove motor oil pan. Will I see broken piston oarts if this is the case?
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
My 1.9tdi ahu made a metal sound when the injector wasn't right.
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
Oil pans a bit of a job to get off only to find that's not what it was. Check the injectors aren't loose. And spray test them in possible. An endoscope type camera in through an injector orifice might be able to see something. Pull timing belt covers forward and physically check the timing belt if you haven't already done so. Oil pan off usually involves holding the engine on a hoist and dropping the front subframe.
 

JorKSX

Registered User
I checked the timing belt. It seems fine to me. The belt is fine and not broken or anything. If I want to remove injectors I have to remive the rocker cover? And then remove bolts that hold injector? And then I just pull the injector out? I have injector testing machine or whatever is called :D
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
That's the same as the 2 ltr pd engines. A bit of a faff but probably easier than sump off. Maybe you might want to pm Adamss24 as he knows these engine inside out.

The injector tester will be helpful.
 

JorKSX

Registered User

I finally made video of the sound. Any help?

Now I get fault code 01376. Engine signal for injector pump.
37-00 Faulty
 
Last edited:

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
That's on two cylinders possibly. Sorry I couldn't be of more help. Car looks nice inside btw. Boost gauge is good.
 

JorKSX

Registered User
Thanks. Car looks nice also outside. Now I need only to get it running again :D

Can I somehow check if the injector pump is fine? If I open the torx srews, then there is the "brain" ?
 
Last edited:

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
I'm not familiar with the layout on those engines I'm afraid. Somebody else's time to chime in.
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)

I finally made video of the sound. Any help?

Now I get fault code 01376. Engine signal for injector pump.
37-00 Faulty
If during the tests you disassemble the power pump of the injection pump then you can receive such a fault code. Delete the code and check again
 

JorKSX

Registered User
If during the tests you disassemble the power pump of the injection pump then you can receive such a fault code. Delete the code and check again

yes I know, I deleted all codes. thers no codes anymore. The metal hitting thing is Starting motor, its broken down what I can tell and when starting it jumps over the "theeths"
But why the engine is not starting I dont know that. I changed engine speed sensor. no effect.
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
s-l1600.jpg
yes I know, I deleted all codes. thers no codes anymore. The metal hitting thing is Starting motor, its broken down what I can tell and when starting it jumps over the "theeths"
But why the engine is not starting I dont know that. I changed engine speed sensor. no effect.
Check for air bubbles in clear fuel supply pipeline. But the more likely possibility is timing. To check the timing you need to lock the crankshaft, Camshafts and injection pump, using a special tools
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)

JorKSX

Registered User
Sorry, just now I heard the noise from your engine in the file you attached. It does not sound like starter motor noise. I would begin to dismantle the rocker covers

It was starter motor. I changed it and the noise is gone.
Now the problem is why it wont start. It gives me always fault code : 01376 ( SPEED SIGNAL FOR INJECTION PUMP DEFECTIVE)
I have changed the engine speed sensor, and checked the wires.
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
Does the code in the library say about the engine speed sensor? Is it not a pump speed sensor problem?
 

JorKSX

Registered User
Only code is 01376. It wont say anything about soeed sensor. Only that speed signal for pump....
 

Samuel c5 Q

Registered User
VCDS Map User
Silver Supporter
He's maybe busy, he responded to a question I had right and quick.
 

JorKSX

Registered User
It did not help me.
It cannot be timing because before oil cange. Engine was running no problem. I even checked timing then. After oil change the engine was running but badly. The timing was still OK.
Then I removed rocker cover and after I put everything back together it wont start. Like the pump wont pump disel.
I dont have anymore ideas. Only the pump. Can I somehow check if pump "brain" is OK?
I read somewhere that if you start engine with air in pump. It will be broken as soon as you start? Is thia true?
Or do I just need to get rid of the air inside pump? And how do I do that?
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
What happened to the starter that caused such strong knocking. Is there a possibility that the starter hit and broke the actuators (6) of the engine speed sensor on the Flyiwheel?
 

Attachments

  • פלייויל.jpg
    פלייויל.jpg
    329 KB · Views: 650

JorKSX

Registered User
theflywheel is fine. I still think that the pump is somehow broken. it wont pump disel into the engine. But can I somehow check it so I can make sure about it?
the fault code says that pump wont deliver info to ecu
 

JorKSX

Registered User
So I have fault code 01376 engine speed sensor for injection pump.
I removed the engine speed sensor and disconnected it. Still 1 fault code. If I remove any other sensor I get new code. So I think this ESS is broken somehow? I did mesurments and it says 832ohm. Somewhere I read that it should be around 500-800ohm. So mine is basically fine. But if I connect it again thers still same fault code.
Can this sensor be the big problem I have? The sensors costs in my local car shop 100€ so is it worth changing it? Or sould I try something else?
 

JorKSX

Registered User
Oh yeah. there are 3 pins, should be named 1 2 3
from the pin 3 to earth i get 0.1v when ignition is ON
all other pins give me nothing
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
The ESS resistance is :895 OHM (At 30 degrees C)
 

amiram

A6 C5 Allroad 2.5L TDI Tip Still on air :)
I do not think ESS is your problem.
Are you sure that the power plug of the injection pump is clean and well connected?
 

JorKSX

Registered User
the strong knocnking sound is now fixed. the flywheel was lose. I dont know how, but I removed transmission and checked thats its lose.
Why it wont start? Pump broken?
 
Top