1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Help Please 2.0 TFSI Owners???

arobson90 Mar 26, 2020

  1. arobson90

    arobson90 Member Team Brill Red TFSI Owners Group saloon quattro Audi A4

    67
    14
    8
    Hi all, I have a 2012 A4 2.0 TFSI and have recently noticed a rattle / ticking noise coming from the engine as located in the below image.

    I'm not sure if the noise was there previously and unnoticed or if it is a new sound. Anyone with a 2.0 TFSI who can confirm if they have this noise too?

    Or anyone have any idea what it could be?

    But most importantly is it possible to upload a video in the first place?
     

    Attached Files:

  2. Avatar

    snack-media
    Advertisement


  3. Booboo

    Booboo Active Member Team Daytona TFSI Owners Group S-line owners group S tronic quattro Audi A4 Black Edition

    338
    68
    28
    Fuel pump is back there. Runs off a cam shaft
     
  4. arobson90

    arobson90 Member Team Brill Red TFSI Owners Group saloon quattro Audi A4

    67
    14
    8
    Yeah that's what I thought. Couple of people on FB suggested chain, but I thought all the chains on this engine were at the front.
     
  5. Booboo

    Booboo Active Member Team Daytona TFSI Owners Group S-line owners group S tronic quattro Audi A4 Black Edition

    338
    68
    28
    The chain is at the front
     
  6. arobson90

    arobson90 Member Team Brill Red TFSI Owners Group saloon quattro Audi A4

    67
    14
    8
    Cheers, that's what I thought.
     
  7. arobson90

    arobson90 Member Team Brill Red TFSI Owners Group saloon quattro Audi A4

    67
    14
    8
    Someone has suggested there is a chain connecting the cams together at the rear, is this correct?
     
  8. DP24v

    DP24v Member

    39
    14
    8
    I had the same thing on my Tfsi and was told by Audi it’s the fuel pump and injectors as the fuel is under extreme pressure and it’s the injectors firing.


    Sent from my iPad using Tapatalk
     
  9. arobson90

    arobson90 Member Team Brill Red TFSI Owners Group saloon quattro Audi A4

    67
    14
    8
    Thanks for the response mate, I've heard that too. Just mine seems to have another rattle. I've had mixed responses from that's normal to a sticking cam valve to failing cat.
     
    Last edited: Mar 28, 2020 at 8:16 AM
  10. Rich76

    Rich76 Well-Known Member TFSI Owners Group Team Phantom S-line owners group Audi A4

    415
    315
    63
    Yeah I had it on my 2010 model , only heard it when it was pointed out to me by a dealer when I was selling the car
     

Share This Page

Do Not Sell My Personal Information