2.0 tdi 170 smoke on idle

Cupra neil

Registered User
Hi I've just bought a 56 170 s-line and I have noticed that if I leave it to idle for a while only when the engine is cold it smokes quite heavy, white/grey fuel smoke I was thinking possible dodgy injector. Has anyone else had this fault?
 

VagCabby

Registered User
As said proberly just condensation, all cars do it on cold mornings, warm air from the engine hitting the cold air outside. I wouldn't worry about it
 

Purdy99

Registered User
Mine does that to, but i just thought being the 170's and having the dpf fitted, its the DPF de clogging itself i always thought anyways.... not saying i'm correct lol

also! i just had the injector mod done about 4 months ago, and still smokes when cold, (not all the time tho)
 

Cupra neil

Registered User
I'm going to try a injector harness tonight as audi said they are common I will let you know if its a success or not
 

Purdy99

Registered User
i hope it works for you, would be interesting to see if maybe mines playing up aswell then,
 

Cupra neil

Registered User
Still does it, going to check the injector values tomorrow, I don't think it's dpf regenerating I've never known a car do it on idle or when engine is cold
 

Purdy99

Registered User
ah, sorry to hear that didnt work, really? common fault then it seems, i hope someone finds out what it is!
 

Cupra neil

Registered User
It was smoke, made you eyes water it was that strong, put a blanking plate on the egr and its been spot on for 4 days now. no lumpy idle and better on fuel. Found the egr to be sticking open very slightly. Getting the car remapped anyway so going to get it mapped out
 

fossie

Registered User
Neil, did you have any issues when the EGR delete was fitted - im thinking of doing this to mine but cant afford to get it mapped out straight away
 

Purdy99

Registered User
ah right, i've had mine mapped not, wooo, but am just about to put not a blanking plate, but a restricting plate on the EGR, would that bring up any faults even tho its been mapped? (and dpf delete)
 

tubby

Registered User
mine a 170 07 does this sometimes not all the time a im a mechanic myself its really fuely the smell makes eyes sting and really lumpy /misfiring on idle the give it a blast it clears its defo fuel i thought egr any ideas id like to know.also had the injectors and harness done with audi in dec 2011....steve
 

csm

Registered User
My car did this a few days ago and again today the smoke would make your eyes water.......... it had a brand new siemens egr valve fitted only a few thousand miles ago. So surely must be something else ?
 

northtim

Registered User
My car did this a few days ago and again today the smoke would make your eyes water.......... it had a brand new siemens egr valve fitted only a few thousand miles ago. So surely must be something else ?

Mine has done it on and off for ages, most noticeable when cold. Always juddery when cold, doesn't often smoke but regularly smells of diesel. EGR valve was replaced in December and made no difference. Injectors were done by Audi about 2.5 yrs ago. Once warmed up it usually runs well and smooth.

Indy garage has done reading and says it is something with injectors but didn't sound very confident. Injectors leaking diesel at wrong part of cycle? Said could mean injector/injectors replacing again, or harness, or something re camshaft. All sounds like ££££ and as Turbo now playing up I have decided to get rid. Turbo can be sorted but injectors can get very expensive and I just can't risk that on a car that is knocking on in age and lowish value now.

Good luck finding the cause, I haven't managed to find a solution despite trawling these forums. Similar symptoms but what works for one doesn't seem to work for another so it is a bit of a lottery.
 

csm

Registered User
Mine has done it on and off for ages, most noticeable when cold. Always juddery when cold, doesn't often smoke but regularly smells of diesel. EGR valve was replaced in December and made no difference. Injectors were done by Audi about 2.5 yrs ago. Once warmed up it usually runs well and smooth.

Indy garage has done reading and says it is something with injectors but didn't sound very confident. Injectors leaking diesel at wrong part of cycle? Said could mean injector/injectors replacing again, or harness, or something re camshaft. All sounds like ££££ and as Turbo now playing up I have decided to get rid. Turbo can be sorted but injectors can get very expensive and I just can't risk that on a car that is knocking on in age and lowish value now.

Good luck finding the cause, I haven't managed to find a solution despite trawling these forums. Similar symptoms but what works for one doesn't seem to work for another so it is a bit of a lottery.

Well i just serviced my car again yesterday as it was due and i was intending selling my car anyway as i would rather just run about in a older car worth about £1500-£2k that way the paranoia of the idiots in asda car parks etc etc is no more or a care in the world about miles on the clock, i do 25k per year so to have a exspensive car can quickly loose a fortune in value if they rack up the miles.

I do have the benefit of my mates snap on diagnostics and it all comes back as good and my dpf filter is fine and re-gens when it should etc etc god knows with these 2.0 tdis though they deffo seem weird compared to the 1.9s ive owned in the past with never a problem.
 

eddscott

Registered User
I know this is an old thread but I've noticed my 170 smoking a bit when I first start it. I tend to start the car about 10 mins before leaving the house in the morning and when going to the car it does seem to be a bit smokey - more so than I remember anyway.

Smoke looks a bit blue too but not sure what that means. Car has had the injectors and loom changed 2 years ago under warranty. Has had DPF and EGR removed and turbo is about 18 months old.

Doesn't do anything else untoward so not too worried.
 

AJB119

Registered User
Hi folks, I’m Currently tearing my hair out over my 2007 170 GT that randomly smokes on idle.

It has a strong fuel smell so I’ve done the following: Injector seals, EGR, Throttle body, Temp sensor, Injector loom, Exchange injectors, Ecu, DPF pressure sensor, Smoke test, Air mass meter, Map sensor. With no joy. The only thing that looks odd is the torsion value is 2.97, but timing seemed ok and when it’s good it’s lovely. When it smokes there can sometimes be a slight mis-fire and the fan kicks in. It’s almost as though the DPF is trying to regenerate itself, although this can occur from stone cold.

Has anyone ever got to the bottom of it?

Any help would be very much appreciated
 

AvantMike

Registered User
Hi folks, I’m Currently tearing my hair out over my 2007 170 GT that randomly smokes on idle.

Has anyone ever got to the bottom of it?

Any help would be very much appreciated

Can’t shed much light but my 170 has a mild version of this. EGR replaced late last year, Indy I use found the old one was sticking open. Used to suffer a slight shudder and go into regen whenever it felt like it leaving noticeably reduced power. Have a stage 1 map on and have had dpf chemically cleaned as well as carbon clean recently. Can still smell fuel in the air after engine shut down but haven’t seen any sign of smoke. Regen seems to be less frequent now but still goes a bit louder and slower for a few miles. Fascinated to know what’s up with these cars.
 
Top