1GB MP3 SD card in Sat Nav+



Does anyonee know whether a 1GB SD card will work in the Sat Nav+ unit.

I've tried to use one but the screen displays - Data Corrupt.

I can read the MP3 files on my PC so the card definitely works.

Any thoughts?
Yep, I've got a 1 gig card in mine and it works fine. Did you format it as FAT or FAT 32? It needs to be FAT and all the files need to be in mp3 format not windows media player format.

You also have to put them in folders.
I did mine: Artist name (one folder), inside that folder create a new folder and call it the album name.

Hope that helps

I've got a SanDisk 1GB SD card in mine, works fine. Didn't do the "FAT/FAT32" as Booster describes, just dragged and dropped the folders over from local drive to SD card, the folders having been set up as Booster describes. I used itunes software to "rip" the files off the CD's, it creates its own folders in "My Music" in explorer, where you can just drag and drop as your leisure.

When I get bored of 10-11 albums on the SD card, I can just delete the files and load fresh music from my library onto the SD card.

I did buy another 1GB SanDisk card on eBay the other day, it was cheaper than the normal sources, but when it arrived, it was an "import" and would not work on my PC. I could get data onto it, but the head unit in the car came up with data error, so I sent it back. I would advise that you purchase "geniune" cards to ensure reliability. I got mine online from "L8shop"

Did you format the new one as FAT? some come formatted as FAT and some come formatted as FAT32, it needs to be fat or the Nav+ will give a read error.
That's very strange as I have two 1GB SD cards formatted as FAT32 which work fine in the Nav+
It may depend on firmware version?

I only had the 04 disc in mine, so an old firmware, I have a new unit for the a6 avant and an 05 disc, I will see if it makes a difference when I get round to installing it.
Reformatted the card as FAT and it nows plays perfectly!!!!

Cheers all.
I've had problems with individual files causing the "Data Corrupt" message before.

I took my iPaq out to the car and deleted folders off the SD card then retried the card until it worked.

Similar threads