1.8T MAF sensor problems

Alan H

Need a V8 or Bi-Turbo.......
Hi all,

This has probably been posted on numerous occasions, but I can't see the harm in reposting it.

If you're having problems with lack of power and the turbo not working properly. (ie trying to spool up on light throttle, but nothing there under heavy accelaration)....

You subsequently have it plugged in to the diagnostics and it comes up with a MAF sensor problem.

Don't go and buy a replacement right away, try a few alternatives first.

1. Remove the MAF snsor and give it a clean with some carb cleaner (don't be too vigorous though, the wire is easily broken)
2. Disconnect the electrical connector on top and inspect the male and female side for oxidization on the connectors. If they are oxidized they can be cleaned with a pencil eraser (for light stuff) for heavier oxidization use a small needle file)

The reason I'm posting this is, as you know I've posted a couple of times asking about my car being down on power.

I tried a couple of things that didn't seem to work, then someone mentioned that a MAF problem can absolutely kill the turbo.

I found that the only thing that was killing this was dry connectors on the electrical connector on the MAF itself.

So before going and spending your hard earned, try these couple of things first.

And to prove it, I've been to the place I bought the car from after work tonight, he found the MAF had created a stored code. He cleared it, I drove around, he checked again and no faults were recorded.

Hope that this saves someone a few quid......
 

CHRIS555

DOPE with added OCD
Thank you Alan - a very usefull post
 
Top