Search results

  1. A

    Gateway swap - coding issue 00303

    Correct, High Beam Assist was an option on C6 FL. Have retrofitted this several times. Pretty straightforward. Requires new rear-view mirror (which includes the CMOS camera), new indicator/high beam stalk, E-CAN. 2 new wires need to be run from the mirror to the gateway for E-CAN. Central...
  2. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Higher or lower in the alphabet doesn't always mean newer or older. It really depends if M is the software or hardware index. The first is usually hardware and software goes second. 4F0 907 468 M should support 3G+ but does not support Extended CAN (ACC, Lane change, high beam assist, etc.) AJAX
  3. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Here is the list of Extended CAN gateways you can use: 26-pin: 4L0 907 468 A, SW: 4L0 910 468 A 4L0 907 468 C, SW: 4L0 910 468 A 20-pin: (you will need this if you want to go to 3G+) 4F0 907 468 G, SW: 4F0 907 468 G 4F0 907 468 G, SW: 4F0 907 468 L 4F0 907 468 G, SW: 4F0 907 468 N 4F0 907 468...
  4. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    @B5NUT - the country coding is RoW - left-hand drive and does not affect the language, unfortunately. But to answer my own question.... I have experimented a bit and found out that actually, the language is not set in the Long Coding, despite of what Ross-Tech documentation says. Instrument...
  5. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Interesting problem... I have upgraded the instrument cluster to the facelift version. All coding done, mileage adjusted, CP removed. The instrument cluster is from Germany, though and even though I changed the coding to switch language of the cluster to English (UK), some messages are still in...
  6. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    OK, it seems the second wire connects to the same place as the existing BEM unit's pin 11. So I'll just use that wire. AJAX
  7. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    According to Elsa, it should work. One wire goes to the Gateway and then continues to the alternator (blue wire). The second wire (black/purple) seems to go the fuse box in the luggage compartment... not yet sure where but hopefully I'll find out. AJAX
  8. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Correct. I'll just make a T-junction off the wire from battery monitor to the alternator somewhere under the dash and extend that wire to the gateway. Should do. AJAX
  9. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Aah, just looked at the wire diagrams and understand how it is done. There is only one wire - going from the battery monitoring unit to the gateway and from there to the alternator. So no second wire from the boot is needed. Good, saved me a bit of dismantling :) AJAX
  10. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Are you sure there is only a single wire going from the boot to the alternator? I remember someone saying thay just tapped the second wire under the engine control unit and re-routed it to the gateway...? Also, how about mirror heating? Are door control units also affected? Right now, my mirror...
  11. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Interesting, will see if I can do this. The alternator is a straight swap? No coding? I understand I will have to only use one wire going to the battery management unit. I will use the existing second wire and re-route it to the gateway somewhere near the plenum chamber. AJAX
  12. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    My car has 145k miles on it, so I guess replacing the alternator is not a bad idea. I didn't see any room underneath to operate to take the voltage regulator off. Is it really that easy? My info is that the engine has to move to replace the alternator. Also, my car is an Allroad so chances are...
  13. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Thanks B5NUT then it is as I suspected. I bought a whole new alternator, which is newer than mine (same specs) and has the FL voltage regulator. I also have the new cable. Now it's down to having the alternator replaced - a PITA job AFAIK. Thanks again AJAX
  14. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Hi all, I'm back with the seat heating problem. Tried switching A/C units but the problem persists. A friend led me to believe this might be due to the battery management. Right now, I have upgraded to the 20-pin gateway but this is not connected to the alternator. I still have the old BM unit...
  15. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Yes it works on 3G but usually doesn't work on 3GP without parametrization. AJAX
  16. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    I would actually be ok with 3G as the only thing available through the online connection is google earth maps and 3G is sufficient for it. 2G is just too slow and by the time the map loads properly I'm already out of the area :)
  17. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Yes that's what I thought. I'm on Vodafone data-only SIM, works fine on LTE in my tablet and phone. It will work with an external USB / Wifi router connected to the MMI. I'm on 767. AJAX
  18. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    I guess your unit comes from an A4, A5 or Q7 originally? Mine is originally an A8 unit and it required parametrization to enable the entertainment fade. The unit is a 4H0 035 670 G so my guess it is around 2011. Which receiver module is the one to get, would you know? I only know it's a Temic...
  19. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    On a better note, I managed to get the entertainment to fade when parking aid is on, which seems to not work for some people :) The one thing that I'm still a bit confused about is that my data connection seems only 2G. The 3G icon just never comes on. Is there some modem settings that I need...
  20. A

    My A6 3.0TDi Avant bit of a rebuild and repair thread.

    Thanks much guys for your help with the heated seats. My settings seem to be correct, so I ran a little bit more diag with VCDS and it appears that it's the actual panel that is broken or loaded with the wrong software. When I try to switch on seat heating via the Output Test function of the...
Top