1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Yet another induction kit question

Discussion in 'A3/S3 Forum (8L Chassis)' started by imported_DeadEye, Mar 23, 2005.

  1. I have heard a couple of poeple say that installing an induction kit causes the MAF sensor problems and can make them fail.

    Why is this?
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    Oiled filters such as K&N CAN cause maf failures, however, mafs fail anyway...They are very fragile and that why Audi now offer a exchange MAF for £70 rather than forking out for £200.
     
  4. Good answer! Thank you.

    The oil gets on the element!

    Vauxhalls give the MAF a blast when you turn the car off - this was supposed to "clean" the ellement. I assume Audi's don't do this?
     
  5. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    No they dont. The trick is to only use a small coating of oil on the filter and clean the MAF once in a while!

    Rich
     
  6. Ive been running an oiled ITG filter for about 20k miles now, not caused me any probs.

    But as Rich says, I made sure it was only lightly covered in oil b4 I installed it.
     

Share This Page