1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XCARLINK iPod to Symphony II issues

Discussion in 'In-Car Entertainment' started by A4Ade, Jul 8, 2013.

  1. A4Ade
    Offline

    A4Ade Back from the dead

    Joined:
    Jul 16, 2008
    Messages:
    81
    Likes Received:
    7
    [Jul 8, 2013]
    A bit of a long shot, but in case anyone here is familiar with the inner workings of the Symphony II....

    I installed an XCARLINK to my Symphony II a month ago, and found that every 5 minutes or so the HU would switch back from CDC mode to radio. I checked the earth, which was good, so assumed a faulty unit and had it replaced. Unfortunately the replacement does the same thing, which leads me to think it's a problem with the HU...

    I tried various tests to see if I could identify what was going on, and eventually narrowed it down to only affecting the "playlist" mode of the XCARLINK. The XCARLINK has 2 modes, if you select CDC1 on the HU the iPod controls are free, and you select music manually using the iPod. If you select CDC2-6, the iPod controls are locked, and instead the XCARLINK passes through one of the 1st 5 playlists from the iPod.

    The main difference, as far as I can see, is that in CDC1 mode, the XCARLINK basically just passes the audio (still digitally) but no track information is sent - the HU just counts Track 1 continuously, ignoring track changes on the iPod. In CDC2-6 when playing a playlist, the track info is also sent to the HU, so it increments each Track no. and correct timing information.

    So, I am wondering, how does the HU deal with track info from the CDC? Is there a specific PIN in the CDC connector that is only used for this info, and which could be causing trouble? It has to be something to do with how the HU communicates with the CDC. I have spoken to the XCARLINK manufacturers, but they don't have an answer.

    Any ideas!?

    Thanks...
    #1
  2. Ads

    Ads

    [Sep 24, 2014]

Share This Page