1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

White smoke, limp mode, oil warning... TURBO GONE?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Naj, Aug 12, 2011.

  1. Naj
    Offline

    Naj Member

    Joined:
    May 8, 2011
    Messages:
    75
    Likes Received:
    5
    [Aug 12, 2011]
    Arggghhhh...!

    My car went in to limp mode, then came loads of white smoke. I stopped the car but then it wouldn't start again. Had to jump start it but still loads of white smoke. Oil warning light came on, literally been drained! Only had it serviced a few months ago and check oil level weekly.

    So does that just leave the turbo..? Whats the damage to repair it? :crying:
    #1
  2. Ads

    Ads

    [Dec 25, 2014]

  3. tdi-man
    Offline

    tdi-man Well-Known Member

    Joined:
    Jul 27, 2009
    Messages:
    1,611
    Likes Received:
    48
    [Aug 12, 2011]
    hope oil pump not gone..
    #2
  4. Originalgeezer
    Offline

    Originalgeezer Member

    Joined:
    Aug 6, 2011
    Messages:
    55
    Likes Received:
    2
    [Aug 12, 2011]
    Without knowing or seeing more, does sound very much like possible turbo failure....
    #3
  5. mrpeng
    Offline

    mrpeng 2.0T Quattro

    Joined:
    Jun 24, 2011
    Messages:
    78
    Likes Received:
    1
    [Aug 12, 2011]
    and not cheap m8 but most of what ive saw on here seems like turbo 1-2k repair depending on new/old who you no etc
    #4
  6. Naj
    Offline

    Naj Member

    Joined:
    May 8, 2011
    Messages:
    75
    Likes Received:
    5
    [Aug 13, 2011]
    Ouch! As its a 7 year old car, I wont go for a brand new turbo but a reconditioned one for £300-400. Hopefully an Audi specialist can fit it for a similiar price.
    #5
  7. FranA3
    Offline

    FranA3 events moderator Regional Rep

    Joined:
    Dec 4, 2008
    Messages:
    7,145
    Likes Received:
    248
    [Aug 13, 2011]
    does sound like a turbo gone to me mate , the oil light is prob where all the oil has been burnt in the turbo so causing the light to come on , hop you didnt drive it with the oil light on tho not a good idea at all , plus driving a tdi with a turbo gone is really dangurous to the engine as the engine runs off the oil and some of the time it revs and revs till it runs out of oil and then engine faliure ive had it happen to me with a bmw 3 series in work to fix it new engine new turbo/intercooler pipes etc... not advised to do so at all tow it if poss to a garage mate
    #6
  8. fletch71
    Offline

    fletch71 New Member

    Joined:
    Oct 4, 2010
    Messages:
    3
    Likes Received:
    0
    [Aug 18, 2011]
    I had a similar thing, but luckily it had just blown the turbo pipe off !
    #7

Share This Page