1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Whistling sound under load and high boost - Loss of power & increased lag

Discussion in 'A3/S3 Forum (8L Chassis)' started by sekenzo, Jul 17, 2010.

  1. sekenzo
    Offline

    sekenzo Member

    Joined:
    Sep 26, 2009
    Messages:
    102
    Likes Received:
    0
    [Jul 17, 2010]
    My car developed a high pitch whistling sound when I put the trottle down. Also experienced loss in power and increased turbo lag. My guess is there is a leak somewhere. I have checked all the hoses in the charged system and they all seems to be fine, any suggestions? Does anyone know if there is a good garage in Sutton (or surrounding) who does boost leak testing?
    #1
  2. Ads

    Ads

    [Dec 25, 2014]

  3. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,554
    Likes Received:
    793
    [Jul 17, 2010]
    i do leak tests.. where abouts are you?
    #2
  4. sekenzo
    Offline

    sekenzo Member

    Joined:
    Sep 26, 2009
    Messages:
    102
    Likes Received:
    0
    [Jul 17, 2010]
    i am at the far south of london close to wimbledon area
    Last edited: Jul 17, 2010
    #3
  5. badger5
    Offline

    badger5 www.badger5.co.uk Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,554
    Likes Received:
    793
    [Jul 17, 2010]
    i am just south of gloucester.. a fair treck for you
    #4

Share This Page