1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Which spark plugs?

Discussion in 'A3/S3 Forum (8L Chassis)' started by RichA3Turbo, Nov 21, 2005.

  1. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    Car wont run properly...firing on 2 or 3 cylinders... think it must be the plugs. They look pretty warn!

    So, what are people using?

    Rich
     
  2. Advert Guest Advertisement


  3. Khufu

    Khufu Well-Known Member

    Joined:
    Jan 2, 2003
    Messages:
    5,704
    Likes Received:
    30
    Denso uridium thingies. That said, my engine has a helluva lot easier life than yours!
     
  4. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    Was looking at NGK iridium... BKR6EIX

    They should be ok!? Using Beu Ultra X at the moment, but took them out and they are v dirty, and gaps look pretty big. It just wont run on all cylinders...Only since its got cold.

    Rich
     
  5. amb276s3

    amb276s3 bird spotter

    Joined:
    Sep 10, 2004
    Messages:
    292
    Likes Received:
    0
    Rich, i recently had melted wires running into the coil packs, may be worth a quick check on them.
    Andy
     
  6. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    Thanks..will take a look!! Pretty sure its the cold weather showing me the plugs have had it!

    Rich
     
  7. Ess_Three

    Ess_Three Active Member

    Joined:
    Feb 19, 2001
    Messages:
    5,383
    Likes Received:
    11
    [ QUOTE ]
    Denso uridium thingies. That said, my engine has a helluva lot easier life than yours!

    [/ QUOTE ]

    I too was running Denso Iridium plugs...IK22s.

    I went up one heat range due to the boost and heat of the engine...pretty good they were too...never caused any problems.
     
  8. RichA3Turbo

    RichA3Turbo ...Watching you!
    Staff Member Moderator

    Joined:
    Jan 6, 2003
    Messages:
    5,089
    Likes Received:
    4
    False alarm! Turns out the injector connectors for racelogic were to blame! Had to bypass it for the time being. Looks like a bit of screenwash got in and crystallised on the pin. D'oH!! The A3/S3 scuttle panel is C R A P ! ! ! ! !

    Going to change plugs anyway as when i checked them last night, they didnt look in the best condition!

    Rich
     
  9. Ryanc

    Ryanc Active Member

    Joined:
    Feb 15, 2004
    Messages:
    1,321
    Likes Received:
    0
    You should run a colder plug with more boost etc.Standard s3 plugs are fine up to 380bhp.
     

Share This Page