1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

What's going on here?

Discussion in 'A3/S3 Forum (8L Chassis)' started by Tricki, Nov 21, 2012.

  1. Tricki
    Offline

    Tricki Getting into it

    Joined:
    Nov 6, 2011
    Messages:
    114
    Likes Received:
    5
    [Nov 21, 2012]
    Had my car on service last week, standard issue + haldex oil and brake fluid. Yesterday the engine light lit up (yellow) and today the ESP light is on permanently. Any clues to what's going on?

    [​IMG]
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. 16Klappe
    Offline

    16Klappe Princess Clap.

    Joined:
    Sep 16, 2008
    Messages:
    5,315
    Likes Received:
    902
    [Nov 21, 2012]
    Check the fuses on top of the battery, remove each one and check for breaks. Clean the connections and refit.

    :)
    #2
  4. Tricki
    Offline

    Tricki Getting into it

    Joined:
    Nov 6, 2011
    Messages:
    114
    Likes Received:
    5
    [Nov 28, 2012]
    Got a diagnose yesterday. Cracked vacuum pipe. Don't know what the ESP light was about though, so will check the fuse box.
    #3
  5. mike.c1979
    Offline

    mike.c1979 Member

    Joined:
    Jul 18, 2008
    Messages:
    55
    Likes Received:
    1
    [Nov 29, 2012]
    Check the MAF connection. When its disconnected, dirty etc, the ESP light comes on.
    #4
  6. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,103
    Likes Received:
    1,180
    [Nov 29, 2012]
    Good call Mike,Waks Wide Web links how to clean maf
    #5

Share This Page