1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Weitec coilovers finally fitted!!!

Discussion in 'A3/S3/Sportback (8P Chassis)' started by smudge_don, Mar 4, 2010.

  1. sub39h
    Offline

    sub39h Active Member

    Joined:
    May 19, 2010
    Messages:
    2,502
    Likes Received:
    5
    [Mar 18, 2011]
    well i asked them to diagnose a knocking at low speeds and they couldn't find anything?

    i'm 99% sure that it wasn't there before
    #41
  2. Lings
    Offline

    Lings Active Member

    Joined:
    Jun 6, 2010
    Messages:
    2,075
    Likes Received:
    30
  3. sub39h
    Offline

    sub39h Active Member

    Joined:
    May 19, 2010
    Messages:
    2,502
    Likes Received:
    5
    [Mar 18, 2011]
    it's only at slow speeds and around half lock
    #43
  4. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Mar 18, 2011]
    Did you change the top mounts when you did coily's as these are a common one to do when changing shocks etc, mine were buggered when I uprated to new suspension.
    Last edited: Mar 18, 2011
    #44
  5. sub39h
    Offline

    sub39h Active Member

    Joined:
    May 19, 2010
    Messages:
    2,502
    Likes Received:
    5
    [Mar 18, 2011]
    smudge_don was kind enough to provide me with new-ish top mounts for them
    #45
  6. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Mar 18, 2011]
    Urmm whats newish Jordanian.
    #46
  7. sub39h
    Offline

    sub39h Active Member

    Joined:
    May 19, 2010
    Messages:
    2,502
    Likes Received:
    5
    [Mar 18, 2011]
    he had them on his car for around 3k miles i believe
    #47
  8. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,161
    Likes Received:
    688
    [Mar 18, 2011]
    :wub:
    #48
  9. FranA3
    Offline

    FranA3 events moderator Regional Rep

    Joined:
    Dec 4, 2008
    Messages:
    7,145
    Likes Received:
    246
    [Mar 18, 2011]
    hey dude ive just seen this , ive just fitted coilovers to mine and ive got a knocking from the rear is your like a metal knocking ???
    #49
  10. sub39h
    Offline

    sub39h Active Member

    Joined:
    May 19, 2010
    Messages:
    2,502
    Likes Received:
    5
    [Mar 19, 2011]
    Yeah but mine's from the front
    #50
  11. FranA3
    Offline

    FranA3 events moderator Regional Rep

    Joined:
    Dec 4, 2008
    Messages:
    7,145
    Likes Received:
    246
    [Mar 19, 2011]
    its a real head scratcher aint it
    #51
  12. Bugsy_27
    Offline

    Bugsy_27 Vorsprung Durch Technik

    Joined:
    Dec 30, 2008
    Messages:
    644
    Likes Received:
    8
    [Jun 5, 2011]
    Did you fit Weitcs Fran? anyone else had this problem with Weitc Coilys or Any for that matter?
    #52
  13. Fivetones
    Offline

    Fivetones Member

    Joined:
    May 11, 2011
    Messages:
    238
    Likes Received:
    17
    [Jun 5, 2011]
    At a guess the front could be an antiroll bar catching (do A3s have drop links, not played with one yet) or maybe just the ARB bushes (or other bushes for that matter.

    TBH I've put coilovers on a lot of cars and these days I change as many of the bushes as possible while I'm doing it. Makes the car feel new and tight again.
    #53
  14. N8
    Offline

    N8 Kowalski Details VCDS Map User

    Joined:
    Jul 4, 2007
    Messages:
    17,161
    Likes Received:
    688
    [Jun 5, 2011]
    He's got V-Maxx from me Lee.
    #54
  15. miv
    Offline

    miv Member

    Joined:
    Dec 9, 2009
    Messages:
    71
    Likes Received:
    1
    [Jun 11, 2011]
    I've just had AP coilovers fitted & have a knocking which I can feel through the pedals. Only at slow speeds and it doesn't matter if you have the wheels on any sort of lock or not. Jacked it up and there's no signs of anything rubbing and I had top mounts and bearings replaced. Might take it back to Awesome.
    #55

Share This Page