1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

water temp guage

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by fenian672000, Sep 17, 2007.

  1. fenian672000
    Offline

    fenian672000 Member

    Joined:
    Nov 24, 2006
    Messages:
    71
    Likes Received:
    0
    [Sep 17, 2007]
    the water tempreture gauge in my A4 is sometimes sitting at 0 then all of a sudden it goes to 90 then settles and sits at 50 ish.......if i switch of the engine and operate the ignition the temp gauge can read different.

    there is hot air from the heaters even with the guage reading zero........is this just a faulty guage or could there be something else?????

    prob just a coincidence but i just got the car back from vag garage as they had it in to get a new key coded as my keys got lost, the battery was also flat so the were messing about with the battery .....then when i drove away the guage stated playing up

    any advice would be appreciated
    #1
  2. Ads

    Ads

    [Oct 25, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    31
    [Sep 17, 2007]
    Sounds supiciously like a faulty temp sender, which is very common on A4's.
    It not only sends the temp to the temp guage but also provides info to the ECU which can cause dodgy idling, stalling and high fuel consumption if it's not working correctly. Easy £20 DIY fix, just remember to release the pressure on the expansion tank before removing the sender, but retighten once the pressure's released otherwise all your coolant will symphon out when you remove the sender.
    #2
  4. jase0851
    Offline

    jase0851 Member

    Joined:
    Oct 8, 2004
    Messages:
    784
    Likes Received:
    1
    [Sep 17, 2007]
    should b at 90 all the time when warmed up
    #3
  5. pembo1976
    Offline

    pembo1976 New Member

    Joined:
    Sep 10, 2007
    Messages:
    25
    Likes Received:
    0
    [Sep 17, 2007]
    Where abouts is the sender? I'm having a similar problem on my A4 so I think thats the way forward. Is it just a screw in device with a plug on the back?
    #4
  6. Neil_S
    Offline

    Neil_S Member

    Joined:
    Jan 18, 2006
    Messages:
    248
    Likes Received:
    0
    [Sep 17, 2007]
    The sender on my 1.9 TDI is on the back of the engine block, you can get alot of access to the sender if you remove the air intake, air filter cover, looks down the back at the bottom rear of the engine and it is there.

    You get alot more access this way.
    #5
  7. pembo1976
    Offline

    pembo1976 New Member

    Joined:
    Sep 10, 2007
    Messages:
    25
    Likes Received:
    0
    [Sep 18, 2007]
    Sorry, I forgot to mention mine is a 1.8T do you know if its in the same place as as the Tdi?

    Cheers
    #6
  8. Neil_S
    Offline

    Neil_S Member

    Joined:
    Jan 18, 2006
    Messages:
    248
    Likes Received:
    0
    [Sep 18, 2007]
    I believe it is in the same place on the 1.8T

    These photos give you an idea of location (this on the 1.9 TDi)

    [​IMG]

    [​IMG]

    If you take off the air intake, air filter housing you should get some decent access to change this sender
    #7
  9. pembo1976
    Offline

    pembo1976 New Member

    Joined:
    Sep 10, 2007
    Messages:
    25
    Likes Received:
    0
    [Sep 18, 2007]
    Thanks for that I'll give it a go.

    Cheers.
    #8
  10. Neil_S
    Offline

    Neil_S Member

    Joined:
    Jan 18, 2006
    Messages:
    248
    Likes Received:
    0

Share This Page