1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Water pump

os360 Feb 9, 2008

  1. os360

    os360 New Member

    10
    0
    1
  2. 96a6v6

    96a6v6 Member

    76
    0
    6
    Sounds to me like you changed the pump just in time :icon_thumright:
     
  3. Bong Water

    Bong Water In two minds

    786
    0
    16
    How many miles has the old pump done?
     
  4. os360

    os360 New Member

    10
    0
    1
    65000 miles
     
  5. S3Steve

    S3Steve Active Member

    1,609
    17
    38
    Lucky you found it before it caused any more damage. I hope you managed to get all the broken impellor pieces out of the block.
     
  6. jojo

    jojo Looking for Boost! Staff Member Moderator Team Daytona Audi S3 quattro Audi A6 Audi Avant Owner Group

    28,846
    3,509
    113
    Changed my Cambelt at 52k miles and the impellor part was intact on mine, but there was signs of slow weeping of coolant around the seals of the impellor, so glad I changed mine, got a metal one after reading comments on here.
     
  7. golf

    golf ***** rent boy VCDS Map User

    1,556
    3
    36
    Did your car ever overheat os360?
     
  8. os360

    os360 New Member

    10
    0
    1
    ive only had it a month and its been pretty cold! but it never overheated just hovered around the 90 mark.
     
  9. Maz

    Maz Moon is made of green cheese

    1,002
    10
    38
    You've had a lucky escape there mate, I got mine done at 65k and it looked fine. Also opted for the metal one for piece of mind.
     

Share This Page