1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

wastegate, n75 question

Discussion in 'A3/S3 Forum (8L Chassis)' started by karl210, Sep 10, 2012.

  1. karl210
    Offline

    karl210 Member

    Joined:
    May 15, 2012
    Messages:
    229
    Likes Received:
    3
    Since ive had my s3 its lost power and i compensated for this by adjusting the wastegate a while back, since then ive fitted a b5 tip, found a few boost leaks and done a full pcv delete with catch can, it ran great for a few days but it seems like its loosing power again, everytime i make it run well, a few days later its back to its usual self.
    1st gear is fine, but when accelerating in 2nd or 3rd the turbo sounds like its working overtime and the car isnt going like it should, it sounds like the turbo is going to explode, theres a loud low pitched hiss and also a high pitched hiss and it doesnt go like it should.
    So ive been thinking, the mods ive done and leaks ive found will the turbo be overboosting and the ecu compensating for this by the n75 valve? is this completely wrong or could it be true? is it worth backing the actuator off and giving it a go or will it just result in less power simples?
    #1
  2. Paradox1
    Offline

    Paradox1 Active Member

    Joined:
    Aug 3, 2011
    Messages:
    1,833
    Likes Received:
    86
    Sounds like a boost leak mate.its air escaping out of the system.double check that all hoses are done up tight and that there are not split or damaged hoses.I've had my fair share of boost leaks,I hear them a mile off lol
    #2
  3. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    728
    You have to be careful putting extra preload on willy nilly, did you see what the actuator pressure is with the N75 unplugged..?
    #3
  4. karl210
    Offline

    karl210 Member

    Joined:
    May 15, 2012
    Messages:
    229
    Likes Received:
    3
    Ive been over all the pipes hence the pcv delete but I cant find anything, my mate is having words with someone with a smoke tester. It was about 6psi on gauge but I plugged the footpump into it yesterday and got 4psi but not sure if it was accurate
    #4
  5. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    728
    I have actually just changed my Actuator as it was leaking air, so a smoke test may find this?
    I got mine from Dan on here ....(beachbuggy)uprated... as the forge ones by all accounts are not very good...
    #5
  6. Dani_B19
    Offline

    Dani_B19 Audi-sports own special child.

    Joined:
    Nov 9, 2008
    Messages:
    7,273
    Likes Received:
    90
    What one has Dan provided for you dave?
    #6
  7. karl210
    Offline

    karl210 Member

    Joined:
    May 15, 2012
    Messages:
    229
    Likes Received:
    3
    should i be able to blow through the large connector that goes to the metal turbo outlet pipe? i would of thought this would be closed or does it close when needed?
    #7
  8. badger5
    Online

    badger5 RIP S3dave Site Sponsor

    Joined:
    May 28, 2004
    Messages:
    7,264
    Likes Received:
    669
    smoke test for the win...
    leaky may well be revealed then...

    you should'nt be hearing hissing...
    #8

Share This Page