1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

vent flaps

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by mattyboyc, Apr 19, 2010.

  1. mattyboyc

    mattyboyc B6 Veteran
    Audi A4 Audi Avant Owner Group TDi Audi Sport Owner Group

    Joined:
    Sep 8, 2009
    Messages:
    1,846
    Likes Received:
    167
    Hi can anyone tell me which flaps the motor with the red arm is supposed to control,i have removed it tested the motor all ok, put back in car and pushed everything but still does not move,the econ button moves the large flap on top of the big round thing in the footwell,also the auto button moves this flap but still no cold air.
     
  2. Advert Guest Advertisement


  3. simon.m

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    i think the red is the cold flap its the one i have a prob with right now
     
  4. mattyboyc

    mattyboyc B6 Veteran
    Audi A4 Audi Avant Owner Group TDi Audi Sport Owner Group

    Joined:
    Sep 8, 2009
    Messages:
    1,846
    Likes Received:
    167
    I push all the buttons and all the arms move except the red one,when the motor is diconnected and the arm moved by hand you can hear a flap banging from where seem to be behind the center vents, i'm going to put one of the other motors on it later and see what it does, can't understand it though as when the motor is out and you put power to it it does a full sweep, reverse the power and it does a full sweep the other way, it was however jammed solid at first so first point of call will be the fuses just to make sure that by pushing the buttons with a jammed motor it hasen't blown any, i'll keep you informed.
     
  5. simon.m

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    i have the same the red one the motor works when its off yet when its on you can hear it moving but not opening right up from the sound of it
    plus when i take keys out for about the first 60 sec you can hear it twiching like its having a fit lol then it stops but my aircon is just not kicking in at all. where abouts are you mate
     
  6. quattrojames

    quattrojames Moderator
    Staff Member Moderator Audi A6 Audi Avant Owner Group

    Joined:
    Mar 28, 2008
    Messages:
    14,043
    Likes Received:
    561
    You've both got Elsa and Etka for guidance yeh....?

    "Removing and installing temperature flap control motor - left V158"

    It looks like you need to slide the heat exchanger out to get access to the flaps, but if you say they're moving by hand Matt then hopefully it's just a motor problem.
     
  7. simon.m

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    hey james yep i have elsa thanks to you lol all though im rebuliding my laptop so ill have to wait till i put it back on mine moves but vagcom says its stuck some times
    but i just dont get cold air at all from it but then my compreser is not coming on well not that i can hear.
     
  8. mattyboyc

    mattyboyc B6 Veteran
    Audi A4 Audi Avant Owner Group TDi Audi Sport Owner Group

    Joined:
    Sep 8, 2009
    Messages:
    1,846
    Likes Received:
    167
    Quick update on this, i can confirm that the motor with the red arm controls the temperature setting on the passenger side, therefore it will only move a little at a time,i found this as a last push of all the buttons, so all my flaps are now flapping but still no cold air con, so she's going for a re-gas tomorrow although it says it's full i'm gonna have it flushed and re-gased.
     
  9. simon.m

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    will have to see how that turns out for you mate can you hear your compresor kicking in
     
  10. mattyboyc

    mattyboyc B6 Veteran
    Audi A4 Audi Avant Owner Group TDi Audi Sport Owner Group

    Joined:
    Sep 8, 2009
    Messages:
    1,846
    Likes Received:
    167
    You can't hear the compressor kicking in but you do get a increase in air flow when you turn it on, so all flaps doing what they should,pump turning on and off and the screen de-mister doing what it should i hope it can only be needing a re-gas,can't think what else it can be, can't get it done untill next week now but will keep you updated.
     
  11. simon.m

    simon.m Active Member

    Joined:
    Oct 5, 2009
    Messages:
    2,747
    Likes Received:
    6
    thanks mate iv just posted a new thread on the truble im having with mine :banghead:
     

Share This Page