1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vag-Com Expert Help Required!!!!!!!!!!!!!!

Discussion in 'VCDS (formerly VAG-COM) forum' started by mickpd3, Apr 21, 2007.

  1. mickpd3
    Offline

    mickpd3 New Member

    Joined:
    Apr 3, 2004
    Messages:
    26
    Likes Received:
    0
    Can my ecu be recoded with vag com NOT to communicate with the following controllers in the log below to prevent the fault codes(18053-18057-01324-01310)...Bear in mind that the engine and ecu were previously in a Allroad 4x4 and now in my A4 FWD..Engine type is A.R.E. These codes will not clear with vag-com and are a constant PITA...Thanks for any help guys.
    --------------------------
    VAG-COM Version: Release 409.1-S


    Chassis Type: 8D - Audi A4 B5
    Scan: 01,02,03,08,15,17,25,35,45,55,56

    -------------------------------------------------------------------------------
    Address 01: Engine
    Controller: 4Z7 907 551 B
    Component: 2.7l V6/5VT 0003
    Coding: 10812
    Shop #: WSC 00535
    WAUZZZ4BZ1N031770 AUZ7Z0Y1496807
    2 Faults Found:
    18053 - Powertrain Data Bus: Missing Message from AWD Controller
    P1645 - 35-00 - -
    18057 - Powertrain Data Bus: Missing Message from ABS Controller
    P1649 - 35-00 - -
    Readiness: 0110 1101

    -------------------------------------------------------------------------------
    Address 03: ABS Brakes
    Controller: 4D0 907 379 D
    Component: ABS BOSCH 5 7402
    Coding: 0265108005
    Shop #: BB 37402
    No fault code found.

    -------------------------------------------------------------------------------
    Address 08: Auto HVAC
    Controller: 8D   
    Note: Excessive Comm Errors

    -------------------------------------------------------------------------------
    Skipping Address 15-Airbags

    -------------------------------------------------------------------------------
    Address 17: Instruments
    Controller: 4Z7 920 980
    Component: C5-KOMBIINSTR. VDO D13
    Coding: 00464
    Shop #: WSC 00183
    WAUZZZ4BZ1N031770 AUZ7Z0Y1496807
    3 Faults Found:
    00779 - Outside Air Temp Sensor (G17)
    30-00 - Open or Short to B+
    01324 - Control Module for All Wheel Drive (J492)
    49-00 - No Communications
    01310 - Level Control System Control Module (J197)
    49-00 - No Communications

    -------------------------------------------------------------------------------
    Address 25: Immobilizer
    Controller: Bit teA dre ss
    Component: e 17 eingeben
    No Faults Found
    or DTCs not supported by controller
    or a communication error ocurred

    End --------------------------------------------------------------------------------------------------
    #1
  2. Uwe@Ross-Tech
    Offline

    Uwe@Ross-Tech Member

    Joined:
    Oct 7, 2006
    Messages:
    130
    Likes Received:
    0
    Oh swell, another one of these:

    [​IMG]

    What do you have in Adaptation Channels 60 of the instrument cluster?

    I'm rather baffled by the 18053 and 01324 codes since the Allroad has a purely mechanical AWD system and therefore should not have a control module for AWD..

    -Uwe-
    #2
  3. mickpd3
    Offline

    mickpd3 New Member

    Joined:
    Apr 3, 2004
    Messages:
    26
    Likes Received:
    0
    Hi Uwe. In adaptation ch 60,it say i have a stored value of 3201..There is nothing in the fields/boxes above.Four blanks... Apparently the allroad has electronic front and rear diff locks.Would this cause the faults???....Also in my last post i forgot to mention that i have a 5 speed fwd A6 gearbox,if that helps any....Thanks for your time and assistance. P.S.The car,engine,gearbox are all UK spec.
    #3
  4. Uwe@Ross-Tech
    Offline

    Uwe@Ross-Tech Member

    Joined:
    Oct 7, 2006
    Messages:
    130
    Likes Received:
    0
    Try 1025 in channel 60, it may get rid of some of those codes.

    -Uwe-
    #4
  5. mickpd3
    Offline

    mickpd3 New Member

    Joined:
    Apr 3, 2004
    Messages:
    26
    Likes Received:
    0
    2 faults are now cleared.Thanks for that Uwe.Any ideas on the other two (18053-18057)?...If i can get rid of these,then the thorn in my side is completely removed.
    #5
  6. Sebastian
    Offline

    Sebastian Member

    Joined:
    Aug 7, 2006
    Messages:
    286
    Likes Received:
    0
    Try coding the ECU to 10512, this should at least get rid of the AWD message. However, please keep in mind that not all ECU's support all possible combinations which means this ECU can be made for AWD only and won't accept FWD codings. Just for laughs, current versions of VAG-COM would give you detailed explanations for all these things automatically... ;)

    http://wiki.ross-tech.com/index.php/2.7l_T_(AGB/AJK/APB/ARE/AZA/AZB/BEL/BES)
    #6
  7. mickpd3
    Offline

    mickpd3 New Member

    Joined:
    Apr 3, 2004
    Messages:
    26
    Likes Received:
    0
    No luck so far Sebastian.I try to input the new code,if im doing it properly (01-engine/recode-07/10512/Do-It) and it just reverts back to 10812. Do i need a WSC code as well, or do a log in to be able to change it?..If not,it indeed seems to be coded for AWD.Thanks.
    #7

Share This Page