1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Urgent help needed the dash has lit up like Blackpool

Discussion in 'A3/S3 Forum (8L Chassis)' started by Paddya3turbo, Jul 15, 2012.

  1. Paddya3turbo
    Offline

    Paddya3turbo Member

    Joined:
    May 7, 2012
    Messages:
    103
    Likes Received:
    1
    [Jul 15, 2012]
    Right guys I'm cruising down motorway and the battery light comes on , then the abs a few mins later with a big red caution symbol on the led bit ! After a few mins I think the alternator is ****ed or a belt to it but the car keeps going ??? Battery doesn't die ,,, completely anyway or not enough to stop the car ? I pull over and can't see anything but ain't got a clue what I'm looking for anyway lol ! I risked it and stopped the engine , all light disappear but after a few mins of car running they come back on ? And then speedo , temp , fuel , rev counter all stop working and a amber battery is sat above the big red flashing caution symbol but again the car is still going ??? After 20 mins speedo and all others started working again and battery light went out just leaving the abs and the big flashing red caution Symbol and when pushing the button on the led it says fault with abs contact workshop ,,, I then switched off ignition again and all lights have now gone out and seem to have stayed out for now anyway ? The battery light does flicker on and off under acceleration now ?

    Anybody got any ideas
    #1
  2. Ads

    Ads

    [Jan 26, 2015]

  3. s33nyboy12
    Offline

    s33nyboy12 Well-Known Member

    Joined:
    May 14, 2012
    Messages:
    1,444
    Likes Received:
    178
    [Jul 15, 2012]
    Alternator .

    Had same on old Saab of mine nearly exact same symptoms. And was alternator on that.
    #2
  4. Paddya3turbo
    Offline

    Paddya3turbo Member

    Joined:
    May 7, 2012
    Messages:
    103
    Likes Received:
    1
    [Jul 15, 2012]
    Thanks mate that's kinda what I'm hoping ! Anyone had this on there Audi ?
    #3
  5. firestorm
    Offline

    firestorm Member

    Joined:
    Jun 15, 2004
    Messages:
    362
    Likes Received:
    2
    [Jul 15, 2012]
    Check the voltage at the battery with the engine off and running. Should be around 11.5-12.6v. 13.5-14v with the engine running.
    #4
  6. Paddya3turbo
    Offline

    Paddya3turbo Member

    Joined:
    May 7, 2012
    Messages:
    103
    Likes Received:
    1
    [Jul 15, 2012]
    Got nothing to test it ! Will try sort something tomoz
    #5

Share This Page