1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unusual engine noise, help.

ant24-7 Nov 21, 2013

  1. ant24-7

    ant24-7 New Member

    4
    0
    1
    Good afternoon, I'm hoping some one can help me or point me in the right direction, I have an Audi a4 2.0l TFSI Quattro and I'm getting a really strange noise from the engine, when running a idel it sounds fine but when it is revved up and as soon as it passes 4000 rmp the engine tone changes, ( it sounds like I have a blown/missing exhaust) it alternates between the two tones, normal and quite loud. When you then start to bring the revs down the engine tones( loud and normal) seem to slow down and the at around 3000 rpm it will stick on one of the tones, and then sort of seem a bit sluggish. I know it's hard to describe in writing but it's really starting to annoy me. Also vag-com isn't showing any thing up on the engine, help please.

    also I have had the PVC valve changed, diverter valve new cam shafts have also being fitted along with chain, tensioner and adjustor.
     
    Last edited: Nov 21, 2013
  2. hades-

    hades- Yorkshire & Humber Rep. Regional Rep VCDS Map User

    9,468
    645
    113
    welcome
     
  3. Andy-R

    Andy-R Member

    67
    0
    6
    Egr?
     
  4. lynallbel

    lynallbel Active Member

    395
    36
    28
    Whats the engine red line?
    Ignorei thought it was a diesel!
     
  5. ant24-7

    ant24-7 New Member

    4
    0
    1
    Hi all, daft question but does the petrol engine have an egr? Also red line starts at 7000. Will this just be a case of starting to change out parts untill the noise goes away?
     
  6. lynallbel

    lynallbel Active Member

    395
    36
    28
    When you are revving the engine are you A driving it, or B revving its at a standstill, if the answer is B then its meant to do that, well i say meant to, i have come across several different makes of petrol cars that wont let you rev them very hard at all when out of gear, so assume the audi is the same.
    Both mine and the wifes petrol v6 and v8 mercs had egr valves, but they were tiny compared to the diesel ones.
     
  7. sebbles84

    sebbles84 New Member

    2
    0
    1
    Iv had a few cone through my garage with similar symptoms and all have resulted in the FSI pump Bering replaced!!
     
  8. ant24-7

    ant24-7 New Member

    4
    0
    1
    Fsi pump bearing? Daft question but where would I find that and how would I go about checking it if it's worn?
     
  9. ant24-7

    ant24-7 New Member

    4
    0
    1
    Update,

    found the problem, balance shaft sprocket was shot, resulting in the the toothed cog having just small rounded stubs and snapping in half, the chain which drives both the balance shaft and oil pump was slipping around and generally sounds shocking,

    New parts fitted where balance shaft module complete with oil pump, new chain, chain tensioner and all new cogs including the one off the end of the crank shaft,

    But good news, it sounds great now, it's like a new engine.
     
  10. Molnboman

    Molnboman Well-Known Member

    1,338
    193
    63
    Jaysus you are very lucky.....that could have been catastrophic if you hadn't Sussed that out. Glad you got it fixed in time.

    BR
    A
     

Share This Page