1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turbo's gone!

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by unikarl, Aug 18, 2010.

  1. unikarl

    unikarl Member

    Joined:
    Mar 19, 2004
    Messages:
    367
    Likes Received:
    2
    Is this a common fault for the turbo to go on a TDI 140?

    Its costing nearly a grand for a new one! Ouch!!
     
  2. Advert Guest Advertisement


  3. rowdyboy

    rowdyboy Member

    Joined:
    Mar 2, 2009
    Messages:
    804
    Likes Received:
    19
    Get it rebuilt at a turbo specialist or get an exchange for a few hundred quid matey.
     
  4. Marc1

    Marc1 Member

    Joined:
    Feb 25, 2008
    Messages:
    728
    Likes Received:
    3
    Which part has failed and was it diagnosed at Audi? They'll only replace the full unit often without a full inspection of the turbo. Which still may not have been the cause. I'd want to know if it's the vanes or impeller shaft that has gone. Id also have it diagnosed at a trusted specialist rather than Audi and like Rowdyboy says have the trbo rebuilt if it's salvageable.
     
  5. Fahim

    Fahim Member

    Joined:
    Dec 5, 2009
    Messages:
    278
    Likes Received:
    1
    How many miles was your car on?

    Do you tend to really use the turbo or do you drive like miss daisy?

    How was the service schedule? Fsh?
     
  6. unikarl

    unikarl Member

    Joined:
    Mar 19, 2004
    Messages:
    367
    Likes Received:
    2
    To be honest most of the time I'm steady away. The place that diagnosed it is an Audi specialist, I can't afford proper Audi prices! The internals have gone on it, the guy mentioned the impeller.

    I've had a new one fitted because I'm doing 50k plus a year so I wanted a warrantied unit that will last... Fingers crossed it will!!
     
  7. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    is the car sorted mate
     
  8. unikarl

    unikarl Member

    Joined:
    Mar 19, 2004
    Messages:
    367
    Likes Received:
    2
    It is. I picked it up last night. Its so much better now, I think the turbo must have had issues ever since I got the car but I just passed it off as normal.

    Got my headlights in too and managed to de-egg them before I put them in so no more orange! How are yours? You liking them?
     
  9. bearder2006

    bearder2006 Member

    Joined:
    Jun 18, 2009
    Messages:
    205
    Likes Received:
    0
    they look right nice mate love them thanks for fitting them
     
  10. danotto

    danotto VAG HUNTER

    Joined:
    Jun 23, 2007
    Messages:
    1,090
    Likes Received:
    1
    how did u de-egg your lights i hate the amber in my headlamps
     
  11. unikarl

    unikarl Member

    Joined:
    Mar 19, 2004
    Messages:
    367
    Likes Received:
    2
    I heated them up then split the glass from the back section. You've then got to put a screwdriver into the orange part and hit it with a hammer. It just pops out.. job done!
     

Share This Page