1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Traction light and glow plug light flashing??

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by shaz, Oct 27, 2012.

  1. shaz
    Offline

    shaz Member

    Joined:
    Oct 19, 2005
    Messages:
    123
    Likes Received:
    2
    [Oct 27, 2012]
    Hi all, got a problem with my b6 - basically on full lock to the right and when driven forward I noticed sometimes that there is rumble,

    Only does it sometimes, today it did it on full lock and the traction control light has come on - switched the car off and now traction light is on and the glow plug light has started flashing?

    Any ideas what this can be?

    Car drives fine, brakes are fine, brake lights are ok also...

    Please advice.
    #1
  2. Ads

    Ads

    [Dec 18, 2014]

  3. shaz
    Offline

    shaz Member

    Joined:
    Oct 19, 2005
    Messages:
    123
    Likes Received:
    2
    [Oct 27, 2012]
    Forgot to mention this is not on my Quattro, it's on a normal b6!
    #2
  4. A3_130
    Offline

    A3_130 Member

    Joined:
    Oct 24, 2012
    Messages:
    85
    Likes Received:
    4
    [Oct 27, 2012]
    Hey I'm new to the forum. Glow plug symbol's flashing on my 2003 A3 and it's giving the fault code 16955, I think my brake light switch is at fault so I'm going to replace it. They're cheap to buy and pretty easy to change though haven't got round to doing it yet. My brake lights still work so assuming the switch is on the way out and not knackered yet.
    #3
  5. shaz
    Offline

    shaz Member

    Joined:
    Oct 19, 2005
    Messages:
    123
    Likes Received:
    2
    [Oct 27, 2012]
    I had this once on my bora but the brake lights weren't working - changed the switch all was fine!

    But now my lights are working and everything seems to work also
    #4
  6. quattrojames
    Online

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,933
    Likes Received:
    489
    [Oct 27, 2012]
    It all points towards the brake light switch, ideally you want to get it scanned, but if you can't I'd change that first off.
    #5
  7. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    15
    [Oct 27, 2012]
    Mine done this before I sold it and noticed my brake lights had failed
    #6
  8. Neilb1
    Offline

    Neilb1 Member

    Joined:
    Oct 13, 2012
    Messages:
    180
    Likes Received:
    2
    [Oct 28, 2012]
    yep i changed replaced the duf bulb and was fine after this
    #7
  9. scottshere
    Offline

    scottshere Member

    Joined:
    Dec 9, 2010
    Messages:
    339
    Likes Received:
    2
    [Nov 9, 2012]
    Shaz did you fix this problem?
    I see from other posts that this could be from the grommets being blocked and water running down into the car

    Mine started with this problem tonight and no rain so im hoping its the brake light switch or a bulb out, not an ECU problem
    #8
  10. marktdisport
    Offline

    marktdisport Active Member

    Joined:
    Jul 14, 2011
    Messages:
    1,195
    Likes Received:
    15
    [Nov 9, 2012]
    Most definatatly brake switch bud cheap fix when it happens try and catch your brake lights in the mirror
    #9
  11. scottshere
    Offline

    scottshere Member

    Joined:
    Dec 9, 2010
    Messages:
    339
    Likes Received:
    2
    [Nov 10, 2012]
    Thanks, i just checked today and my brake lights arnt working, the one in the rear window is though... This makes me wonder
    Mate at work says he noticed i had a bulb out last week, so will check them all tomorrow and see if changing the faulty one works
    If not then off to the stealers for a switch... :undwech:
    #10
  12. shaz
    Offline

    shaz Member

    Joined:
    Oct 19, 2005
    Messages:
    123
    Likes Received:
    2
    [Nov 13, 2012]
    Hi mate, sorry for late reply, yes it was the brake switch, bought it from GSF and fitted myself,

    Thanks to all the guys on here for the advice

    Thanks
    #11
  13. scottshere
    Offline

    scottshere Member

    Joined:
    Dec 9, 2010
    Messages:
    339
    Likes Received:
    2
    [Nov 13, 2012]
    Same here.... Fixed mine too yesterday
    Turns out it was a blown bulb !!! Easy fix :cool:
    #12

Share This Page