1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Traction Control Wont Turn On When Driving?

Discussion in 'A3/S3 Forum (8L Chassis)' started by VTI_EG_DAN, Feb 14, 2009.

  1. VTI_EG_DAN
    Offline

    VTI_EG_DAN Member

    Joined:
    Nov 2, 2008
    Messages:
    93
    Likes Received:
    0
    Hey all,

    I went to view an s3 today, decided not to buy it in end as all seemed a bit dodgy!

    but the traction control wasnt working properly

    it would turn on when the ignition was on, and stay on when started the car, but as soon as u start driving, it would turn straight off, and then the button for it wouldnt do anything, and u couldnt turn it back on?

    is this a common fault? and is it easy fixed?

    just so i know when i go and look at other s3s!

    Cheers Dan
    #1
  2. S3 NIK
    Offline

    S3 NIK Member

    Joined:
    Mar 5, 2007
    Messages:
    190
    Likes Received:
    0
    The esp light comes on with ignition then should go out as with the air bag light for example. The only time its lit is when you turn it off as a reminder its been manually turned off and when its actually working ie when you are losing traction, when this happens it flashes on and off quickly.
    Nik.


    #2
  3. VTI_EG_DAN
    Offline

    VTI_EG_DAN Member

    Joined:
    Nov 2, 2008
    Messages:
    93
    Likes Received:
    0
    yeh this light was on the whole time when driving, and when car was started the button wouldnt do anything, and warning light would just stay on
    #3
  4. S3 NIK
    Offline

    S3 NIK Member

    Joined:
    Mar 5, 2007
    Messages:
    190
    Likes Received:
    0
    In which case there's a fault somewhere and it would need a diagnostic check to pin point the fault.
    Nik.

    #4
  5. benr
    Offline

    benr Member

    Joined:
    Jan 21, 2008
    Messages:
    819
    Likes Received:
    0
    Yep there will be a problem with it. as mentioned above It whould be off after you have started the car unless you turn it off by pressing the button.

    it could be a common problem as some of the sensors are known to fail, but needs a diagnostic scan to find which one. I wouldnt buy it until its sorted though
    #5
  6. Yaz
    Offline

    Yaz Member

    Joined:
    Oct 2, 2008
    Messages:
    225
    Likes Received:
    0
    More than likely the longitude sensor or something like that has failed and needs replacing. This is a common problem with the TT also.

    When this happens, its ok to drive the car but just means the ESP wont work!
    #6
  7. mad max
    Offline

    mad max sixth gear

    Joined:
    Jul 17, 2006
    Messages:
    338
    Likes Received:
    0
    has the battery been played with because there is an plug in on the back of it and if its not making a good connection would cause this type of fault.easy to check and could save you money if it is this
    #7
  8. <tuffty/>
    Offline

    <tuffty/> Badger 5 Edition Staff Member Moderator

    Joined:
    Sep 14, 2008
    Messages:
    15,759
    Likes Received:
    1,276
    Mine used to come on due to the problem I had with my MAF. It did take a while but after a bit of spirited driving it would come on and sta on until I turned the ignition off.

    VAGCOM would help you... it may be a fault that a cheap fix or a way of getting a good price on an otherwise decent car.

    The seller must have known there was a prob (even if they don't know what it is)

    Good luck finding a car, its a buyers market and the right one will come along :)

    <tuffty/>
    #8
  9. HTC
    Offline

    HTC Active Member

    Joined:
    Jan 11, 2004
    Messages:
    3,413
    Likes Received:
    0
    Can also come on with a bad ABS sensor.
    #9
  10. benr
    Offline

    benr Member

    Joined:
    Jan 21, 2008
    Messages:
    819
    Likes Received:
    0

    Yep but the abs light would also be on.
    #10

Share This Page