1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Traction Control Warning Light Coming On

Discussion in 'A3/S3 Forum (8L Chassis)' started by adamf200, Dec 31, 2009.

  1. adamf200
    Offline

    adamf200 Member

    Joined:
    Oct 27, 2009
    Messages:
    71
    Likes Received:
    0
    [Dec 31, 2009]
    Hi all,

    I have a 2000 A3 T-Sport Quattro.
    When I go on a journey of more than 15 minutes the traction control warning light comes on and stays on until I swith the ignition off.
    It then doesnt come back on until another journey lasts at least 15 minutes!
    It doesnt flash it just stays lit up.
    Any ideas?
    Could it be a serious problem?
    Car still seems to drive normally!
    #1
  2. Ads

    Ads

    [Sep 22, 2014]

  3. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    972
    [Dec 31, 2009]
    Is it the only light that comes on or does the ABS light come on too?

    You could do with getting your car scanned really.
    #2
  4. ianysm
    Offline

    ianysm Active Member

    Joined:
    Oct 10, 2008
    Messages:
    1,003
    Likes Received:
    0
    [Dec 31, 2009]
    Could be a faulty wheel speed sensor?
    #3
  5. adamf200
    Offline

    adamf200 Member

    Joined:
    Oct 27, 2009
    Messages:
    71
    Likes Received:
    0
    [Dec 31, 2009]
    Its just the traction control light that comes on.
    #4
  6. voorhees
    Offline

    voorhees Moderator Staff Member Moderator

    Joined:
    Dec 18, 2005
    Messages:
    15,123
    Likes Received:
    1,186
    [Dec 31, 2009]
    longitude sensor
    #5
  7. naquiss
    Offline

    naquiss Member

    Joined:
    Oct 30, 2007
    Messages:
    42
    Likes Received:
    0
    [Jan 4, 2010]
    Could be a faulty brake switch. You won't know for sure until you get the fault log from a scan.
    #6
  8. mk1chopper
    Offline

    mk1chopper Missing the S3

    Joined:
    Oct 17, 2006
    Messages:
    1,093
    Likes Received:
    10
    [Jan 4, 2010]
    Could be your suspension geometry is out, mine came on permantly on my S3 after I had a front spring replaced, after i had the 4 wheel alignment done it went away. But no harm in having a scan done either
    #7
  9. c_dog
    Offline

    c_dog Member

    Joined:
    Apr 24, 2008
    Messages:
    92
    Likes Received:
    0
    [Jan 4, 2010]
    This is also a symptom of either the G200 (lateral acceleration sensor) or G202 (longitudinal acceleration sensor) being incorrectly calibrated or faulty on facelift models - I think is the same on pre-facelift. Although as others have said get a scan done and see what codes are found.
    #8
  10. marcyp
    Offline

    marcyp Only me

    Joined:
    Mar 28, 2009
    Messages:
    126
    Likes Received:
    0
    [Jan 4, 2010]
    could also be the maf, that was the reason it came up on my qts
    #9
  11. gazsutton
    Offline

    gazsutton I MISS MY LCR!

    Joined:
    May 3, 2010
    Messages:
    38
    Likes Received:
    0
    [May 4, 2010]
    this has happend to mine. noticed it the other day was driving, then went round a sharp corner and it came on.
    restarted the engine and it didnt come on again till the next day, restarted it, and again it hasnt been on since.
    #10
  12. landopanda
    Offline

    landopanda Member

    Joined:
    Apr 6, 2009
    Messages:
    143
    Likes Received:
    0
    [May 4, 2010]
    Happend to me a while back and turned out that my haldex control unit was goosed, had to get a new one. Get it scanned then you will know.
    #11
  13. gazsutton
    Offline

    gazsutton I MISS MY LCR!

    Joined:
    May 3, 2010
    Messages:
    38
    Likes Received:
    0
    [May 8, 2010]
    how much did that cost?????
    #12
  14. cupra20v.t
    Offline

    cupra20v.t New Member

    Joined:
    Aug 2, 2006
    Messages:
    29
    Likes Received:
    0
    [Aug 5, 2010]
    bringing back an old post as i am pulling my hair out with my issue.

    my 2001 S3 amk engine has the traction control light constatntly, i bought the car with the light on.

    I scanned the car and the only fault was lateral acceleration sensor, electric circuit failure, i have had it scanned by audi and ordered a new lat accel sensor at £124. my mate is an audi technician and he fitted the new sensor and "zero'd" it off using vag.com. however the fault code would not clear and the light on the dash stayed illuminated.

    He came around tonight to have another bash at it with an older style vagcom which the instructions he has relate to as the first time he did it he had an updated machine and some modules and measuring blocks had been changed and we couldnt get into the relevant section and follow the instruction presicely.

    anyway old software machine used tonight and still it would not work, the fault code would not clear, he ended up manually coding the lateral acceleration sesnor and the light went out but then the ABS light began to flash and when i drove the car it beeped like mad. the 4wd didnt work nor the ABS. we scanned the car and abs came up clean no faults but the lat accel sensor code was still there even thought the light was off.

    he undone his coding and the ABS light went out and traction light came back on, no beeping but still no 4wd.

    we are stumped at this and he is emailing audi technical for assistance but i have a few questions of my own

    would a dodgy maf cause the traction light to come on? if so, would a dodgy maf show up on a vag com scan?

    would a revo remap cause the traction light to come on?

    i hope someone can help as its spoiling my fun in the car, i love it to bits but not being able to take round abouts or bends safely is doing my nut.

    thanks in advance.
    Last edited: Aug 5, 2010
    #13
  15. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Feb 10, 2011]
    i am looking to buy a car with this tc light on .. i have read alot about this but whats the most common problem to fix this
    #14
  16. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    972
    [Feb 10, 2011]
    I wouldn't touch that car until you've seen what the fault codes are! It could be anything from a wheel speed sensor (£70) to the Haldex control unit (£600).
    #15
  17. Welly
    Offline

    Welly VX220 SC Driver :)

    Joined:
    Aug 5, 2009
    Messages:
    10,699
    Likes Received:
    117
    [Feb 10, 2011]
    Dodgy MAF is the most common, however normally comes on quicker than 15 mins.

    My traction control light is always on, as a sensor on the underside of the master cylinder has gone.

    I haven't changed it deliberately as it doesn't cause problems, and it also means I don't have to turn the traction control off manually....

    Lazy I know...
    #16
  18. DavidW
    Offline

    DavidW Member

    Joined:
    May 7, 2006
    Messages:
    211
    Likes Received:
    1
    [Feb 10, 2011]
    Does a fault in some part of the system actually disable the ESP or just bring the light up to tell you there is a fault?
    #17
  19. s3dave
    Offline

    s3dave TFSI Hybrid

    Joined:
    Nov 11, 2009
    Messages:
    10,120
    Likes Received:
    729
    [Feb 10, 2011]
    There are quite a few sensors that can bring the esp light on inc MAF
    #18
  20. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Feb 11, 2011]
    when cars first started the light is off . but if you release hand brake and roll it will come on and stay on untill you switch it of and start it again..
    but you roll car and straght away its on again
    #19
  21. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Feb 11, 2011]
    i used to have a ibiza cupra 1.8t and that was maf that caused the light to stay on.
    #20
  22. Westy
    Offline

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,297
    Likes Received:
    972
    [Feb 11, 2011]
    If the light is coming on as soon as you start rolling I'd think it'll be one of the wheel speed sensors.
    #21
  23. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Feb 11, 2011]
    ok mate cool cheers.. ill get some one to vag com it
    #22
  24. karls s3
    Offline

    karls s3 Member

    Joined:
    Feb 5, 2011
    Messages:
    226
    Likes Received:
    1
    [Feb 13, 2011]
    right i got the car home and where will i find the ecu plug so i can get vag com on it..
    #23

Share This Page