1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

traction control light on?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by marnie2k, Apr 8, 2010.

  1. marnie2k
    Offline

    marnie2k Member

    Joined:
    Apr 5, 2010
    Messages:
    310
    Likes Received:
    0
    hey guys i think i just need some re-asurance here. i have a 55 reg audi a3 2.o tdi dsg s-line and the esp light is on. i have spoken to 3 individual parties (audi, vw tps and a vw specialist i know) and i told them my issue. i told them what i did which was put the vag on it and it brought up "brake pressure sensor" and as soon as i mentioned this to them they all said straight away ABS pump and its a common fault. now i have a nice car and i want it fixing properly with no shortcuts but i aint in any rush to throw away £800 for a abs pump unless im 100% sure nothing else can be done to fix it (and by this im thinking of second hand abs pump, re-condition my abs pump, replace any sensors or modules) please guys if you have any solutions please let me know other wise im gonna have to by the pump from tps! thanks guys
    #1
  2. tdisportuk
    Offline

    tdisportuk Member

    Joined:
    Mar 20, 2009
    Messages:
    460
    Likes Received:
    0
    this probs wont help you. but i know someone with a seat loen 1.6 2005 with the same problem. ESP light remains on no matter what.


    how old is the car?
    #2
  3. marnie2k
    Offline

    marnie2k Member

    Joined:
    Apr 5, 2010
    Messages:
    310
    Likes Received:
    0
    its a 2005 55 reg, it is a common fault from what every one tells me, if i have to buy a new pump then shall be it but i am just looking for alternatives ..........
    #3
  4. edition
    Offline

    edition Active Member

    Joined:
    Nov 1, 2007
    Messages:
    1,428
    Likes Received:
    0
    Brake sensor is the brake sensor a cheap part at the pedal...... Can be changed in minutes if it's that that's wrong!
    #4
  5. 1wheelonly
    Offline

    1wheelonly cabriolet

    Joined:
    Oct 14, 2007
    Messages:
    2,060
    Likes Received:
    4
    are all your brake lights working, this is a very common thing as edition has said. id be checking/changing that first, there only a few quid.
    #5
  6. remslie20
    Offline

    remslie20 Member

    Joined:
    May 22, 2009
    Messages:
    135
    Likes Received:
    0
    I ahve a similar problem with my car, 57 plate a3 s/b. Esp comes on randomly but once i switch off ignition and restart car it dissapears. Can be months or sometimes hours between it happening. Cars been into Audi 5 times now for same fault but nothing shows on the diagnostics and they haven't yet managed to replicate the fault whilst the car has been into them which leaves me frustrated and with a car that i'm finding increasingly annoying to own. Audi told me that this is not a common fault and when i mentiond barke sensors i was told that it couldn't possibly have anything to do with that as it doesn't play any part in the ESP system which i thought sounded a bit strange! Last i was told was to bring the car in when the esp light comes on again so they can get the diagnostics on whilst it's up. So far it's came on three times since once at half twelve on a saturday when the workshop had just shut, once at half seven in the evening and once when i was on the motorway 100 miles away!! Typical!
    #6
  7. marnie2k
    Offline

    marnie2k Member

    Joined:
    Apr 5, 2010
    Messages:
    310
    Likes Received:
    0
    well ive found some second hand ones with guarantee on them for £175+vat so i might give them a go, plus my friend who is a vw/audi specialist said he will code them for free so i think im gonna give that a try if not then its the new 1 from audi :(
    #7

Share This Page