1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

traction control / esp light

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by clough103, Aug 9, 2010.

  1. clough103
    Offline

    clough103 Member

    Joined:
    Apr 15, 2009
    Messages:
    76
    Likes Received:
    1
    [Aug 9, 2010]
    was driving along today and the esp light came on. tried pressing the button on the dash but it wouldnt go off. 30 secs later the light disappeared. On way home from work did it again, came on randomly and then went off about 30 secs later

    any ideas folks, have i got a problem?

    cheers
    #1
  2. Ads

    Ads

    [Dec 22, 2014]

  3. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,933
    Likes Received:
    489
    [Aug 9, 2010]
    It could be a few different things, its probably best to try and arrange a scan with VAGcom to diagnose rather than offering you random guesses.
    #2
  4. xs2man
    Offline

    xs2man Member

    Joined:
    Jun 4, 2008
    Messages:
    791
    Likes Received:
    16
    [Aug 10, 2010]
    As said above, best arranging a scan.

    My A3 had a similar problem, that may or may not have been the steering angle sensor. Can't say if thats what yours is, but who knows? Dunno if this forum has one, but most vag forums I'm on have a list of guys with vagcom, and its just a case of finding whoever is closest to you rather than paying the dealers.
    #3
  5. quattrojames
    Offline

    quattrojames Moderator Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,933
    Likes Received:
    489
    [Aug 10, 2010]
    Yeah I think there's a sticky with VAGcom owners listed in the VCDS section.

    I don't know where the OP is?
    #4
  6. sniffy_smiffy
    Offline

    sniffy_smiffy Member

    Joined:
    Mar 18, 2010
    Messages:
    115
    Likes Received:
    0
    [Aug 10, 2010]
    My ESP light is on permanently @ the mo. My VAGcom scan identified my brake light switch (under steering wheel) is faulty.

    Only £10 from the stealers, if your lucky! Could be lots I things though m8. Good luck.

    Vagcom is easy to use and is a free download for the "lite" version.
    Only about £15 for the USB KKL lead from flea-bay. Just search google or VCDS forums etc.

    Getting my switch done when I get my new Brembo Discs & Ferodo DS2500 brakes fitted.
    #5
  7. paulsb
    Offline

    paulsb Member

    Joined:
    May 20, 2010
    Messages:
    138
    Likes Received:
    0
    [Aug 12, 2010]
    if you've had the tracking done or replaced any arms then that also bring the light on.
    #6
  8. wheymonster
    Offline

    wheymonster Member

    Joined:
    Mar 12, 2013
    Messages:
    50
    Likes Received:
    0
    [Oct 12, 2014]
    Hi all, I also have an ESP problem. When i start the car, all is fine then a few miles in to a journey my ESP comes on and i cant accelerate. This is where it gets interesting - when i try and accelerate with this problem, the car judders when revs as if something is blocked and light smoke comes from the exhaust. The smoke doesn't smell like brakes or clutch and the fault is intermittent. After checking the MAF / EGR / front ABS sensors, I took it for a spin and although it did it again, it took longer to do so (coincidence?) and when it did do it again, I seemed to be able to rev through it whilst stationary. At my wits end, i sat on my driveway with it idling and the ESP light would come on without me doing anything... Hopefully getting it scanned today - does this sound familiar or does anyone have any suggestions?

    Thanks
    #7

Share This Page