1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Today's task.... Vent pod boost gauge

Craig Cull Apr 5, 2014

  1. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Well, I've never fitted one of these before so it could go one way or the other.
    It looks fairly self explanatory but that doesn't mean a lot lol!
    I will post this afternoon with finished results! 😜

    [​IMG]
     
  2. ANDYTQ

    ANDYTQ Well-Known Member

    1,186
    106
    63
    I just use torque ap on my phone you can have multiple gauges as well,i have a really good screen mount.
     
  3. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    [​IMG]

    this one ?
    simple to fit have you got the part to connect the pipework up ?
    i powered mine to the vent lights so they dimmed lit etc with normal lighting
     
  4. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Yeah came as a full kit, I just wired it to the lights so it lights up at the same time as the dash lighting. Also the same colour as the dash lights. Definitely worth having.

    [​IMG]
     
  5. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Didn't know they were very accurate, from what I've been told. I'll try it see how it compares :)
     
  6. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    While your here bez, it doesn't seem to hold boost, it's not the Intercooler or anything related. Still goes like stink like, do you think the waste gate could be blowing open slightly? Gonna do some logs and have a play tomorrow, what do you think?
     
  7. lynallbel

    lynallbel Active Member

    395
    36
    28
    Craig how come its showing a vacuum?
     
  8. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Ignition wasn't on mate
     
  9. lynallbel

    lynallbel Active Member

    395
    36
    28
    I didnt realise it an electric gauge, in my mind it was the capilliary version.
     
  10. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    It's got the electric sender, but doesn't do a thing until the engine is running or the ignition is on.
     
  11. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    [​IMG]
     
    jdp1962 likes this.
  12. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    the needle should be at 0 when engine off
    i think you have a dodgey one.
     
  13. hades-

    hades- Well-Known Member VCDS Map User

    9,482
    646
    113
    whets it sit at when engine running ?
     
  14. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    According to the instructions it should be at 20hg + 10 in vacuum on idle, which it is. It sits at zero when the ignition is on.
     
  15. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Ignition on -

    [​IMG]


    Ignition on with engine running -

    [​IMG]
     
  16. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    I realised what I've done. I just flicked the lights in to take a picture, but I didn't have the ignition on. That's why it wasn't showing anything on the gauge. Does it look right from the pics above?
     
  17. D2NY G

    D2NY G Well-Known Member

    1,088
    132
    63
    that looks spot on fella, they easy to fit wunt mind one in mine
     
    Craig Cull likes this.
  18. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Cheers bud, yeah it was fault straight forward, just need som plastic trim removal tools so you don't mark the dash. The rest is fairly straight forward. Only issue I had was getting the vacuum hose through the bulk head. The American instructions show a grommet, which is on the wrong side on our cars. So I just nipped it in through the rubber wiring loom cover, then under the ECU, jobs a good one :)
     
    Big Al and D2NY G like this.
  19. bigmoylan

    bigmoylan Member

    45
    0
    8
    Sorry for the thread revival, I was just looking at these and wondered if it would fit in the drivers side vent between the steering wheel and the door?

    Thanks
     
  20. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Afraid not mate. The vent is designed for the left vent next to the steering wheel, as a direct fit. I suppose you could probably make it fit, but I wouldn't like to try.
     
  21. sabaxter

    sabaxter Active Member

    465
    27
    28
    Do you have a link from where you purchased this gauge?
     
  22. bigmoylan

    bigmoylan Member

    45
    0
    8
    Thanks for the info, bit disappointing but what can you do, have you had any trouble from it with the heaters blowing hot??

    They're on awesome Gti mate. £110 plus postage for a full kit.
     
  23. Craig Cull

    Craig Cull Well-Known Member

    2,442
    1,383
    113
    Had no problems at all, but then again I don't really use the vents for heat.
    You can also buy them from psi tuning for a similar price for he full kit. That's where I got mine from.
     

Share This Page