1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Three quick questions.

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by madmiketyson, Dec 17, 2010.

  1. madmiketyson

    madmiketyson New Member

    Joined:
    Mar 31, 2010
    Messages:
    18
    Likes Received:
    0
    Hey, I just have a couple of quick questions that will hopefully be easy for you guys to answer.

    1) I am due a service according to the display and I am wondering what parts I need to get hold off. Its an A4 Cab 3.0 Quattro Automatic with 42k on the clock.....Is it just the spark plugs, air filter/oil filter + oil I need to buy, or am I missing anything....This is my first service with this car so want to get it spot on.

    2) My brake warning light has been flashing up for a while now. When it first came on, I took it to the garage, but my brake pads look brand new, everything seemed fine...Did a bit of research in the manual and found it would be related to my Brake Fluid levels.....Went back to the garage as it looked fine to me, was told if anything there was a little too much fluid in there, soaked a bit out and the light went off...happy days! Three days later, it came back...At first it was intermitent, flashing when I started the car and then every so often.....Now, a month down the line and still being told theres nothing wrong with the brake fluid level, it stays on almost constantly.....Does anybody have any ideas what that could be/how to get rid of it?

    3) I saw a thread like this last time I searched here but there was no conclusive answer.....Underneath my car makes a horrible grinding noise when turned to full lock.....Garage said probably the CV joint....However, it only makes this noise when it is/has been raining! I remember that nobody had solved this in the last thread I read....Wondered if anyone found the answer yet?

    Thanks in advance, will check back in a couple of hours!
     
  2. Digger1

    Digger1 Member

    Joined:
    Feb 23, 2010
    Messages:
    439
    Likes Received:
    1
    which brake light are you referring to ? ie; ESP
     
  3. madmiketyson

    madmiketyson New Member

    Joined:
    Mar 31, 2010
    Messages:
    18
    Likes Received:
    0
    On the screen where it tells me my range left etc...There is a red exclamation mark in a triangle.
     
  4. madmiketyson

    madmiketyson New Member

    Joined:
    Mar 31, 2010
    Messages:
    18
    Likes Received:
    0
    Nobody? :/
     
  5. quattrojames

    quattrojames Moderator
    Staff Member Moderator

    Joined:
    Mar 28, 2008
    Messages:
    13,988
    Likes Received:
    522
    Have you had the car scanned for error codes?

    The red brake symbol is usually indicative of a weak battery when you start the car, causing the ABS ecu to record a low voltage error.
     
  6. coyote

    coyote Member

    Joined:
    Dec 15, 2007
    Messages:
    217
    Likes Received:
    8
    In answer to number 1 - CLICK HERE choose the year of your A4 and it will bring up the service schedule.

    Hope this helps
    Steve
     

Share This Page