1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thermostat or Temp Sensor

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Chrismawa, Oct 22, 2013.

  1. Chrismawa
    Offline

    Chrismawa Active Member

    Joined:
    Sep 19, 2011
    Messages:
    252
    Likes Received:
    30
    [Oct 22, 2013]
    My A4 1.9TDI 130 doesn't get to 90 on the temperature display. After reading around on here it seems it will be either the thermostat or temperature sender. Is there any way to tell which? Or just a case or trial and error?
    #1
  2. Ads

    Ads

    [Oct 22, 2014]

  3. Bradderz_1988
    Offline

    Bradderz_1988 Dont replace it, Upgrade it !!

    Joined:
    Aug 19, 2010
    Messages:
    3,287
    Likes Received:
    113
    [Oct 22, 2013]
    Will more than likely be the thermostat given there track record in audi's !!
    #2
  4. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    793
    Likes Received:
    8
    [Oct 22, 2013]
    If the stat has failed stuck open then you should notice that the engine is slow to warm up and the heater doesn't work well.The CTS is more for smooth running
    #3
  5. S3 GAZ
    Online

    S3 GAZ Member

    Joined:
    Dec 17, 2006
    Messages:
    364
    Likes Received:
    8
    [Oct 22, 2013]
    Change the stat first its £10 and is the easier of the 2 to replace. Drain the coolant or top up as youl loose some in the process
    #4
  6. Mike.M
    Offline

    Mike.M Well-Known Member

    Joined:
    Oct 11, 2003
    Messages:
    1,742
    Likes Received:
    84
    [Oct 22, 2013]
    If it is the stat and it's stuck open the car will very slowly get upto 90 if at a standstill and keeping the revs to about 2k. I had this but once I took the stat out discovered that a location lug had broken off the stat elbow and got stuck not allowing it to close, but this is a rare occasion.

    If there is no change to the temp after doing the above then the sensor is the next culprit.
    #5
  7. S3 GAZ
    Online

    S3 GAZ Member

    Joined:
    Dec 17, 2006
    Messages:
    364
    Likes Received:
    8
    [Oct 22, 2013]
    When my stat was on its way out the temp would go up to 90 if I was pushing the engine a bit as soon as took some stress of the engine ie going downhill then the temp needle would drop almost to the bottom. Also it seemed to take ages to heat up in the winter.
    #6
  8. Chrismawa
    Offline

    Chrismawa Active Member

    Joined:
    Sep 19, 2011
    Messages:
    252
    Likes Received:
    30
    [Oct 22, 2013]
    Cheers lads think ill go for the thermostat first then!
    #7
  9. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 1, 2013]
    Is there any preferance on make of stat?

    ECP are selling Circoli ones for 3 quid odd at the moment.

    Should I replace the housing at the same time?
    #8
  10. bradh
    Offline

    bradh Active Member

    Joined:
    May 23, 2013
    Messages:
    386
    Likes Received:
    29
    [Nov 1, 2013]
    im a fan of buying genuine vw/audi thermostat's as i find the cheep ones fail more regularly might cost a tad bit more but should last longer
    #9
  11. Mike B
    Offline

    Mike B Member

    Joined:
    Jul 10, 2007
    Messages:
    793
    Likes Received:
    8
    [Nov 1, 2013]
    Don't buy ECP.Put one in an S3 last year and it only lasted a few weeks
    #10
  12. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 1, 2013]
    Genuine it is then.

    How much G12 will i need to refill the system?
    #11
  13. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 1, 2013]
    think i have found out? allow for 5l...

    worth using gen g12 or get some antifreeze with g12 spec?
    #12
  14. bradh
    Offline

    bradh Active Member

    Joined:
    May 23, 2013
    Messages:
    386
    Likes Received:
    29
    [Nov 1, 2013]
    It's g13 now from vw lol I buy genuine stuff last time but I bagged 2 bottles of eBay for price of one he he
    #13
  15. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 1, 2013]
    Want to do it this weekend really and looking now I'm not paying out for genuine antifreeze. ECP finest will do I reckon.
    #14
  16. neilA4
    Offline

    neilA4 Member

    Joined:
    Aug 8, 2009
    Messages:
    188
    Likes Received:
    0
    [Nov 2, 2013]
    #15
  17. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 2, 2013]
    Cheers, I thought people must use other than Audi own as thats rediculous price.

    Off to Audi in a bit for the stat and oring then ECP for some antifreeze think they do Triple QX stuff.
    #16
  18. B5NUT
    Offline

    B5NUT Well-Known Member VCDS Map User

    Joined:
    Feb 6, 2010
    Messages:
    2,347
    Likes Received:
    267
    [Nov 2, 2013]
    Unless you going to flush the system it not recommended to mix the vag anti freeze, as there will still be loads left in the engine & heater matrix. You also don't need 5 litres I use a 50/50 mix of G13 & water but you could go lower, you will only need at most 2 bottles of G13 for the job you are doing, it's not worth mixing it with other brands.
    #17
  19. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 2, 2013]
    After all that I ended up getting a part from my local motor factors as my 3 local audis didn't have 1 in stock!

    Unfortunately I missed your message B5NUT and have bought some antifreeze for the job. I guess I'll give the system a flush then.

    Should have it all sorted tomorrow.
    #18
  20. quiksilver_jake
    Offline

    quiksilver_jake New Member

    Joined:
    Nov 4, 2013
    Messages:
    5
    Likes Received:
    0
    [Nov 4, 2013]

    I replaced mine in my 52 A4 1.9 tdi 130 with the ECP one 2-3 weeks ago and I'm sure it's gone again, unless I have an air lock...? I think I may replace it with a genuine one before I do the temp sensor but not sure on the price from the dealers~?
    #19
  21. glenandem
    Offline

    glenandem Member

    Joined:
    Sep 23, 2012
    Messages:
    563
    Likes Received:
    20
    [Nov 4, 2013]
    i replaced both parts last year with gen and been fine all year then this morning,first frosty morning and it took a fair while to get to 90.
    must have been in stop start traffic for a good 25 mins and was still at 70 but im just putting it down to these 1.9 engines just dont get very hot and struggle to get up to temp in cold conditions!
    #20
  22. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 4, 2013]
    Audi quoted me 17 quid i think it was the other day. But surely you would change the temp sensor before changing the stat again. I changed both on mine.
    #21
  23. quiksilver_jake
    Offline

    quiksilver_jake New Member

    Joined:
    Nov 4, 2013
    Messages:
    5
    Likes Received:
    0
    [Nov 5, 2013]

    I would but the stat is sooo easy to do do whereas the temp sensor seems impossible to get to and I have asked the question on the forum regarding the difference between green and black as I have a black one on the car but ecp supplied me a green one. They also do not do new o rings and clips so I dont know what to do.
    #22
  24. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 5, 2013]
    Just remove the top boost pipe then you can get to it fairly easily.

    ECP do seem to of stopped doing the clips and rings, I bought a temp sender with clip and oring off them in January but when I bought the other day they said they had none, thankfully I had a spare clip and I have a box of orings.

    I had a green one come out and green back in. Your not looking at the fuel temp sensor are you?
    #23
  25. quiksilver_jake
    Offline

    quiksilver_jake New Member

    Joined:
    Nov 4, 2013
    Messages:
    5
    Likes Received:
    0
    [Nov 5, 2013]
    I dont think so ? I'm taking off the plastic engine cover and looking over the back of the engine down the left side, it looks to be right? It is sitting at an angle slightly upside down?
    #24
  26. Paul_TDi
    Offline

    Paul_TDi Member

    Joined:
    Jul 1, 2010
    Messages:
    219
    Likes Received:
    7
    [Nov 5, 2013]
    Yer thats the one.
    #25

Share This Page