1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Thermostat and coolant temp sensor (G62) location on 2.0 petrol

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by Az, Apr 8, 2013.

  1. Az
    Offline

    Az Hard slammed!

    Joined:
    Jun 11, 2008
    Messages:
    1,026
    Likes Received:
    1
    Can anyone point me in the direction of both parts mentioned in the heading for a 2.0 NA B6 engine please? (can't remember engine code)

    Thanks in advance,
    Az
    #1
  2. Mike_B
    Offline

    Mike_B Member

    Joined:
    Aug 22, 2011
    Messages:
    215
    Likes Received:
    1
    Not sure if this helps much, but my Haynes says "On petrol engines, the thermostat is fitted to a distribution housing on the left hand side of the cylinder block, behind the coolant pump position" . Depending on the engine code, there seems to be varying degree of dismantling to get to it.

    The coolant temp sensor info is "On all models, an engine coolant temp sensor is located at the rear of the cylinder head, whilst on some engines, a second sensor is fitted to the radiator outlet pipe".

    Mike.
    #2
  3. Az
    Offline

    Az Hard slammed!

    Joined:
    Jun 11, 2008
    Messages:
    1,026
    Likes Received:
    1
    That's great, thanks very much for the info mate, I'll have a look out for those positions then. :)
    #3
  4. cookiesvw
    Offline

    cookiesvw Member

    Joined:
    Sep 22, 2012
    Messages:
    90
    Likes Received:
    0
    I know this doesn't help but on my 1.8t I changed the temp sensor and it was one of the most fiddle and frustrating jobs I've had to do. I lowered my gfs tt at weekend and that felt easier.
    #4
  5. madmike01uk
    Offline

    madmike01uk Member

    Joined:
    Mar 7, 2013
    Messages:
    414
    Likes Received:
    2
    I'm doing mine on Saturday, did you take the y boost pipe out? I think this would make it easier
    #5
  6. CEC
    Offline

    CEC Exhausted

    Joined:
    Dec 29, 2010
    Messages:
    8
    Likes Received:
    0
    Hi Guy's,

    I have the same problem only mine is the 3.0 v6,Should I be looking in the same place ???
    #6

Share This Page