1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TFSI Help Please

Discussion in 'Audi S4/A4/A4 Cab (B7 Chassis)' started by steve123a, Aug 17, 2010.

  1. steve123a
    Offline

    steve123a Member

    Joined:
    Nov 20, 2006
    Messages:
    245
    Likes Received:
    0
    I have been having a bit of trouble with my 2.0 Tfsi, It started to stutter a bit under full load and has been in and out of the garage for the past month and a half. It has had all the usual things checked and also just had a service.

    Firstly they have tested it and run the faults through the computer and gradually they have gone down from 7 faults to 3 faults, the last thing replaced was the maf sensor, which seemed to help for a short while and now it's back to as it was before with the engine management light back on.

    The garage have been very good in trying to sort the problem out, but even they are struggling to work out what's wrong with it, the fault codes now seem to indicate a vacuum problem and when the car is idling and you take the oil filler cap off, there is a real sucking vacuum noise and the car starts to almost cut out.

    If anyone can have a check on their car with the same engine and see if they get the same result I would really appreciate it? Or if anyone has any suggestions.

    Many Thanks Steve
    #1
  2. Marrow
    Offline

    Marrow Member

    Joined:
    Mar 18, 2009
    Messages:
    589
    Likes Received:
    3
    Sounds like a PCV (pressure control valve) fault mate or possible coil packs ?
    #2
  3. steve123a
    Offline

    steve123a Member

    Joined:
    Nov 20, 2006
    Messages:
    245
    Likes Received:
    0
    I have changed that twice now, once earlier on and again today just incase there was an issue it
    #3
  4. steve123a
    Offline

    steve123a Member

    Joined:
    Nov 20, 2006
    Messages:
    245
    Likes Received:
    0
    The garage also changed the coil packs, didn't make any difference.
    #4
  5. Marrow
    Offline

    Marrow Member

    Joined:
    Mar 18, 2009
    Messages:
    589
    Likes Received:
    3
    Er dont know then sorry mate try taking it to a specialist vag tech / awsome gti depends were your based ?
    Has it been back to Audi what do they say ?
    #5
  6. steve123a
    Offline

    steve123a Member

    Joined:
    Nov 20, 2006
    Messages:
    245
    Likes Received:
    0
    It's in an audi specialist at the moment, does your car have the same engine? if so could you check if you get a vacuum when you open the oil filler at idle?

    Thanks
    #6
  7. Marrow
    Offline

    Marrow Member

    Joined:
    Mar 18, 2009
    Messages:
    589
    Likes Received:
    3
    Ye same engine will check tonight for you mate !
    #7
  8. auroan
    Offline

    auroan Active Member

    Joined:
    Jan 28, 2004
    Messages:
    1,668
    Likes Received:
    5
    Which specialist ? Some are more "special" than others....
    #8
  9. goon
    Offline

    goon Member

    Joined:
    Jul 31, 2006
    Messages:
    323
    Likes Received:
    1
    sounds like a breather pipe problem,check the crankcase vent system for a blockage.
    #9
  10. DTM1
    Offline

    DTM1 Member

    Joined:
    Jul 24, 2009
    Messages:
    60
    Likes Received:
    0
    steve, how many miles has your DTM done?
    #10

Share This Page