1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

temp prob since cambelt and waterpump?

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by glenandem, Jan 31, 2013.

  1. glenandem

    glenandem Active Member

    Joined:
    Sep 23, 2012
    Messages:
    635
    Likes Received:
    27
    hi guys, i recently replaced the cambelt and waterpump on my 1.9tdi and since then ive lost a few mpg and the temp takes alot longer to get to 90 and when im stationary it drops to around 60-70ish so i replaced the coolant temp switch and also the thermostat today with both gen vag parts and still doing the same, all since i did the cambelt and waterpump?
    elec fan not on either so thats not keeping it cool, i wouldnt be so bothered but im sure the ive lost about 4-5 mpg
    any ideas?
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    did it bleed up ok ?
     
  4. glenandem

    glenandem Active Member

    Joined:
    Sep 23, 2012
    Messages:
    635
    Likes Received:
    27
    think so pal, i had to rev it to 2k for a wee bit to get it up to 90 degrees than if you leave it to idle it goes back down to 70ish, the heater blows hot air ok too and its never overheated?
    i didnt disconnect the bulk head pipes to bleed it but im pretty certain its not got an airblock as it would overheat or wouldnt get hot air would i?
     
  5. glenandem

    glenandem Active Member

    Joined:
    Sep 23, 2012
    Messages:
    635
    Likes Received:
    27
    Forgot to mention when I did the work I put an egr blanking plate on, could this be affecting the temp as its not allowing hot exhaust gases back into the engine and maybe it's affecting mpg too, even though i thought that blanking the egr was supposed to help?
     
  6. cruisinbeatz

    cruisinbeatz Member

    Joined:
    Jan 10, 2013
    Messages:
    71
    Likes Received:
    0
    From my understanding of the tutorials on here people seem to be getting slightly more mpg with the egr delete, or rather thats the theory anyhow.
     
  7. hades-

    hades- Yorkshire & Humber Rep.
    Regional Rep VCDS Map User

    Joined:
    Jul 8, 2008
    Messages:
    9,394
    Likes Received:
    623
    what stat did you fit ?
    oem or after market
     
  8. glenandem

    glenandem Active Member

    Joined:
    Sep 23, 2012
    Messages:
    635
    Likes Received:
    27
    Hi guys yes it was a gen stat from tps and the egr blank I've fitted thrm to other cars
    And they have improved mpg by 1-2 here and there but I'm just thinking with this temp and mpg issue Is it related to egr blank maybe, might swap it back and see if it helps as both the usual parts have been replaced with gen too!
     

Share This Page