1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TDi Fan on Constantly/ ECON light too!

Discussion in 'A3/S3/Sportback (8P Chassis)' started by N7 JNS, Apr 26, 2011.

  1. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 26, 2011]
    Hi all!
    My first post after much trawling of posts, but now a bit confused and some help/advice would be much appreciated.

    Mine is a 2005 2.0TDi S-line with the B series head. This I know as the first snag was coolant loss, so i thought the head was maybe the cause! After some searching around under the bonnet there was evidence of a leak around the bottom right hand corner of the radiator (n/s). Mysteriously after topping up the system, and jigging/ wiggling around some of the pipes, the leak stopped.....? Now however the large fan(of 2) on the same side now runs continuously and I have disconnected it. (The plug was full of coolant when diconnected) and i now get the 18080 code on my "budget" reader. Curiously now I cant select AUTO on the climate control either and it is permantly set to ECON. All fuses seem to be OK! Is this one linked fault or Air Con and a Fan Control Module seperatly perhaps?

    Thanks in adavance for any help!!

    N7JNS
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. FranA3
    Offline

    FranA3 events moderator Regional Rep

    Joined:
    Dec 4, 2008
    Messages:
    7,145
    Likes Received:
    246
    [Apr 26, 2011]
    that fan sounds like the air con fan if it wont let you turn it on to auto reconnect it and see if you can turn it back to auto
    #2
  4. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 27, 2011]
    Thanks for your reply!
    On the way to work this morning all seemed ok, ECON light out and AUTO mode appeared normal. However, this afternoon whilst in traffic the car started to idle erratically then cut out. On restarting both the ECON and AUTO lights stayed on, with the added bonus of code 19557 on my reader still with the 18080. BTW, the fans are still disconnected at the moment if that is affecting anything?(But still run on after recoonecting even when engine is cold!) Is there something common these faults? Sounding kind of expensive, so any help greatly appreciated!!

    N7JNS
    #3
  5. FranA3
    Offline

    FranA3 events moderator Regional Rep

    Joined:
    Dec 4, 2008
    Messages:
    7,145
    Likes Received:
    246
    [Apr 27, 2011]
    hmm that is a strange one pm nhn (nige) he is a bit of a wizz with electric's etc.. he might be able to help further
    #4
  6. The Engineer
    Offline

    The Engineer Member

    Joined:
    Apr 25, 2011
    Messages:
    342
    Likes Received:
    20
    [Apr 27, 2011]
    It took me a while to realise a similar problem on my A3.
    The fan was on very loud as soon as i started the car. eventually found out
    when i set the heating console to "Low" the radiator fan would come on.

    if i then turn the control completely off by pressing the "-" sign (minus button) until the heating console goes off,
    the fan would go off but takes around 10 seconds to do so.

    Not sure about your cutting out or fault codes but im sure someone will come up with a resolution.

    Hope this helps
    #5
  7. roman3000
    Offline

    roman3000 Member

    Joined:
    May 14, 2010
    Messages:
    330
    Likes Received:
    3
    [Apr 28, 2011]
    I knew ive seen that code somewhere before "code 19557" it came up a few times when i was researching the intake manifold flap fault, and the problem you describe was mentioned. Seams like your intake manifold flap is sticking and causing the fan to act odd since they both share the same fuse. Have a search on here and you will find more info on it.
    A new intake manifold flap is £200 from GSF and is very easy to fit if your going to do it yourself.
    #6
  8. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 28, 2011]
    Thanks so far for the info. Have searched through the site a bit more and it does seem possible that igv fault could be the root cause of the fan problem. Is the throttle body part from Eurocarparts at £226 for the BKD engine the unit that covers the igv/egv? I am curious as to how the two faults are linked!!! as I hope that I dont need the throttle body AND Fan Control assys. That said, I am off to France in June and would like to be able to trust the car again so far away from home!!

    Cheers all,

    N7
    #7
  9. roman3000
    Offline

    roman3000 Member

    Joined:
    May 14, 2010
    Messages:
    330
    Likes Received:
    3
    [Apr 28, 2011]
    I bought mine from GSF car parts for £200, cheapest i could find, i think i asked for a little discount.
    I dont know anything else about the fan problem since mine was only the throttle body, but i would start by replacing the throttle body first then see if that helps since yours is faulty. It might just be the throttle body and you wont need to replace anything else apart from maybe the fuse.
    #8
  10. Boydie
    Offline

    Boydie Boycie VCDS Map User

    Joined:
    Dec 24, 2006
    Messages:
    2,831
    Likes Received:
    192
    [Apr 28, 2011]
    Searh V157 Fault on here
    #9
  11. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 28, 2011]
    Boydie et all!

    Thanks for the link and advice, one of many I've looked through today!!!.I just hope by changing the manifold it will solve all the problems!. Just wish I had access to Vagcom to get some more info on the snags. Hoping to get a decent price from TPS in Mallusk if I need it as my old man works up that way and may get one at trade!!

    Thanks all

    N7
    #10
  12. Boydie
    Offline

    Boydie Boycie VCDS Map User

    Joined:
    Dec 24, 2006
    Messages:
    2,831
    Likes Received:
    192
    [Apr 28, 2011]
    Where you from mate?

    I am in Greenisland.
    #11
  13. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Apr 29, 2011]
    Remove your IMF & open it up to check if the teeth have broken 1st, before dropping few hundred on new 1, if broke then 2nd user or new.

    Also note you said the contacts were full of coolant, whats to say the short isnt causing the issue, afterall water & electrics dont bode well together :)

    I would get a hot air gun/hair dryer & dry out the plugs 1st just to be sure.
    #12
  14. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 29, 2011]
    Boydie,

    I'm in the Swindon area, left along time ago, but oldies still in Norn Iron. Old man works in Mallusk for Agn@ws, so trying to get a bit more info that way, but vw don't recognise the 17559 code. If I need the IMF hopefully TPS will come in at a decent price trade!!

    NHN

    The contacts are well dried out now as this has been going for over 3 weeks, with the car parked up for 2 of them! F8 fuse OK and fan still runs straight away when I reconnect it, without the ignition even being on!!

    Will remove the IMF to have look as you suggest, nice long weekend to do it!!

    N7
    #13
  15. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,321
    Likes Received:
    1,229
    [Apr 29, 2011]
    If IMF is intact & functioning, then could even be a faulty fan unit, these are known of on 8P's aswell tbh.

    I was in Cirencester earlier, shame as could of had a look at it.
    #14
  16. N7 JNS
    Offline

    N7 JNS New Member

    Joined:
    Mar 2, 2011
    Messages:
    11
    Likes Received:
    0
    [Apr 29, 2011]
    I'm gonna have a look later when I get some peace this evening. Don't want to order parts unless I now its gonna fix it!!! Out of interest, where abouts are you, I work over towards Witney:salute: but live south of M4/ Swindon! Looks like my retrofit cruise control and alloy wheel refurb is on the back burner for now!!!
    #15

Share This Page