1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TDi 170 - hesitation at 3500 rpm in 4th - oil under bonnet - Tandem pump?

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Cossie_boy, Jul 30, 2012.

  1. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Jul 30, 2012]
    Hi guys,

    I really hope this rings a bell with someone, recently bought my dream A3 2.0 TDi 170 Quattro, paying a lot more than I wanted.

    Noticed that about 3500 rpm always in 4th and occasionally in 3rd I get a slight hesitation, fine in 1st and 2nd, smooth idle, good cold start.

    Went in for a service and health check at Audi today and im told the fuel has oil in it due to a leaking tandem pump in the fuel tank :(

    Googled this and lots of info, apparently 15k faulty ones were recalled?

    My car had the injectors done in January it seems so ok there, although on the history print out it mentions fuel contamination in 2009 at 12k miles so need to investigate what they mean!

    But I noticed oil on the drivers side sound proofing underside of the bonnet, and a little bit towards the back.

    Pretty much each post mentioned rough idle and poor cold starts which mine doesnt :/

    Audi have quoted £800 :sadlike:

    Surely if it was this it would be running rough and hesitate in every gear?

    Another thing confusing me is someone mentioned a tandem pumo under the bonnet on the right side?

    Any other suggestions or advice much appreciated

    Many thanks in advance

    CB
    #1
  2. Ads

    Ads

    [Sep 16, 2014]

  3. Originalgeezer
    Offline

    Originalgeezer Member

    Joined:
    Aug 6, 2011
    Messages:
    55
    Likes Received:
    2
    [Jul 31, 2012]
    Something I would like to see some replies to, as I have a hesitating 170 TDI - but mine does seem to do it first, second and third as generally under full throttle such as pulling onto the motorway, or overtaking which can be somewhat disconcerting.

    It has just been for the injector recall and had clung to the hope it maybe related but its not different and nor did Audi notice the issue. I have also checked to see if any fault codes are logged and there is nothing!
    #2
  4. Gti Jazz Blue
    Offline

    Gti Jazz Blue Active Member VCDS Map User

    Joined:
    Feb 26, 2007
    Messages:
    1,655
    Likes Received:
    6
    [Jul 31, 2012]
    I'm pretty sure that the Tandem Pump is on the right of the block as you look at the Engine, it is a combined fuel pump and vacuum pump. The pump in the Tank is the lift pump and I wouldn't expect that to have oil anywhere near it.

    I am more familiar with the PD140 unit, but can't see the basic layout changing that much with the 170.

    Paul
    #3
  5. antmax7
    Offline

    antmax7 Member

    Joined:
    Nov 10, 2009
    Messages:
    306
    Likes Received:
    2
    [Jul 31, 2012]
    Just take it back to the dealer you bought it from a week ago and insist audi fix it!
    Get audi to give you a written quotation
    #4
  6. max69vk
    Offline

    max69vk Active Member

    Joined:
    Apr 3, 2012
    Messages:
    760
    Likes Received:
    43
    [Jul 31, 2012]
    Check your fuel filter before anything else, Audi seem to have forgotten about doing this on any servicing & it makes a big difference to the car! Just behind the OS headlight, 6 torx screws, pull the filter if its any colour other than white or light grey replace it. AFAIK the faulty tandem pumps affected the 140 more than the 170 so I'm not convinced this is the issue, also you'd probably notice some vacuum issues too as the tandem pump is what 'creates' the vacuum for the brake servo & other systems. If by some stretch of the imagination it does turn out to be the tandem pump you can by a new genuine unit from a well know auction site for around £200 & fit it your self. Also have you had your injectors checked that they are fitted correctly?
    #5
  7. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Jul 31, 2012]
    Hi guys,

    Thanks for the comments, its so frustrating, I drove to work today and it is such a nice car I really dont want to end up not liking it!

    I called the place I got it, CarGiant, I know I know! and they said they would only repair it there, I do not want to take it back to them, nightmare to get to for me, i dont trust them and just fear it would come away worse than went in.

    I shall check the fuel filter tonight so thanks for the info.

    Yes they have put tandem on the quote and implied its inside the tank, maybe not them, need to check this with them.

    When in Audi yesterday no fault codes came up.

    Started on the button this morning and perfect idle, its just that 4th gear, weird!

    Spoke to the Audi place it was always serviced at this morning, I know injectors were done 7 months ago, and found out it had the wrong fuel put in twice, first time it wasnt started up but second time, 18 months ago, involved a tank drain, fuel filter and fuel seals? I was really hoping it may have had the tandem changed already and could have taken that route :/

    Geezer- yours does yours do this in 4th and 5th or just in the lower gears?

    I need to clean the oil off round the engine to establish if its coming back again.

    Thanks again for the info, a tiny light at the end of the tunnel :)
    #6
  8. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Jul 31, 2012]
    #7
  9. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Jul 31, 2012]
    [​IMG]

    What I saw when removing

    [​IMG]

    I know diesel contains an amout of oil :/

    [​IMG]

    Looking down into the filter pot

    [​IMG]

    Its obvious something have sprayed up onto the soundproofing, I know now how relevant this is, the monkeys claimed to have changed the oil and filter and i dont recall seeing this when I first looked at the car, made me think did they start it with the filler off, or is this related to the tandem pump?

    [​IMG]

    The inside of the cover has clearly had some oil shooting around


    So, a new filter fitted, I dont know how Audi tested the contamination, but from the **** on the old fuel filter i guess that would be enough, I am also now thinking I shot myself in the foot by telling them I have a 28 day warranty from the hole i bought it from, they were probably rubbing their hands...

    As always thanks in advance for any comments of help

    CB
    Last edited by a moderator: Aug 20, 2014
    #8
  10. jamie408
    Offline

    jamie408 New Member

    Joined:
    Aug 4, 2011
    Messages:
    29
    Likes Received:
    1
    [Jul 31, 2012]
    just wondering why your reving a derv past 3k a lot that i have driven give up after 3k so i change gear
    #9
  11. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Jul 31, 2012]
    I am a bit confused as im sure they said the tandem pump was in the tank, but its to the right of the engine isnt it?
    #10
  12. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 1, 2012]
    Looked at the old filter and fuel in the box its sitting in this morning and it is very black and oil like :(

    I cannot seem to get my head around where this oil has come from, if it is the fuel pump they say, does the tandem or lift pump in the tank have oil in them? as Audi said it could be the oil seals leaking in the pump

    Another point which could be useful, on checking, 18 months and 20k ago it had the wrong fuel put it in and had a tank drain and new fuel pump...seals, if these seals are the same ones leaking now, what would be the life expectancy on these? just a thought if they have failed would audi uk get them done goodwill?

    any help much appreciated guys, stressed.com!
    #11
    makem3 likes this.
  13. max69vk
    Offline

    max69vk Active Member

    Joined:
    Apr 3, 2012
    Messages:
    760
    Likes Received:
    43
    [Aug 1, 2012]
    Wow, thats not good at all, even worse than mine was & thats saying something!

    Possible causes can be the tandem pump or the injector seals (or injectors not seated correctly). The tandem pump is on the nearside (right hand side if looking at it from the front) & has a big black pipe going into the top of it from the brake servo.

    In your situation I'd take the car back to where you bought it & get them to fit a new tandem pump, even if its not actually faulty you've got yourself a new pump! If the problems persist I'd then take the car back to Audi as it can only really be an injector issue after the tandem pump & it will be covered by them after the replacement.
    #12
  14. SAiLO
    Offline

    SAiLO Enthusiast VCDS Map User

    Joined:
    May 7, 2009
    Messages:
    937
    Likes Received:
    33
    [Aug 1, 2012]
    My fuel filter was as black as yours Cossie_boy, when I replaced it last weekend. PD140.
    #13
  15. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 1, 2012]
    Went to another Audi specialist today, before I had even said the word, he said its the Tandem pump.

    He said he done 2 this week alone and had a few old pumps there, apparently this is what has caused problems with the injectors and they are trying to get Audi to acknowledge this.

    His quote was £550.

    I now need to either try and get the place I got it from to understand this and agree to pay for it to be done here, or try and hope Audi UK may do something for me on this.

    Good to know though for anyone else having this, and as you said Max if this doesnt solve the problem I can revisit the injector route
    #14
  16. SAiLO
    Offline

    SAiLO Enthusiast VCDS Map User

    Joined:
    May 7, 2009
    Messages:
    937
    Likes Received:
    33
    [Aug 2, 2012]
    [​IMG]
    #15
  17. Ste_Nova
    Offline

    Ste_Nova Active Member

    Joined:
    Apr 20, 2012
    Messages:
    1,225
    Likes Received:
    43
    [Aug 2, 2012]
    why not get the place you got it from fix it?
    #16
  18. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 2, 2012]
    It was cargiant...
    #17
  19. antmax7
    Offline

    antmax7 Member

    Joined:
    Nov 10, 2009
    Messages:
    306
    Likes Received:
    2
    [Aug 2, 2012]
    just let them fix it then get an independent specialist to check their work will be cheaper
    also make them aware you will be doing this:icon_thumright:
    #18
  20. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 2, 2012]
    Ok, ive spoken to them tonight and I have to fax over the 2 diagnostics and quotes, both say same, Audi is £805 and Audi Specialist is £545, ill say no more until I hear as dont want to jinx it :tapedshut:

    But, I did speak to Audi UK and they said although there is no known, or aknowledged, fault with the tandem pumps yet, the parts have a 2 year guarantee. So, 18 months ago it had new...fuel pump seals...fitted, but i cant seem to establlish if they were Tandem or Lift in the tank ones, it was due to having wrong fuel put it, any thoughts?
    #19
  21. The Governor
    Offline

    The Governor Active Member

    Joined:
    Mar 21, 2012
    Messages:
    436
    Likes Received:
    65
    [Aug 3, 2012]
    I think you're covered by the Sale of Goods Act and any fault apparent within the first 6 months is considered to be have been there at the point of sale and therefore the responsibility of the dealer.

    Do not negotiate on that point, do not pass go, just collect you repaired car from car giant with proper evidence of a proper repair. Their 28 day warranty is just a load of nonsense, 6 months is your legal entitlement.
    #20
  22. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 4, 2012]
    Thanks guys for all the help

    After LOTS of back and forth they have agreed to pay the Audi specialist for the PARTS to fix it, this means I have to fork out at worst about £180, although he said its probably 2 hours instead of the 3

    Not the exact result I wanted, however I am going with this, means I dont have to make 2 hour journeys to them, i have no confidence they would fix it properly, i would not be at all suprised if it can out with body damage or scratchs, and the stress of it being in there and waiting to hear all out ways the cost.

    Apprently their policy is to have it back and fix it and if taken anywhere else they only pay for parts, at one point someone said they would possibly pay the trade price they get them for rather than what id be charged, have to laugh really! but are paying the garage direct anyway.

    Its booked in for Wednesday so hopefully all should be ok by the evening!

    I shall write a complaint letter to state the case and ask for something towards the labour costs, im not holding my breath but have nothing to lose!
    #21
  23. The Governor
    Offline

    The Governor Active Member

    Joined:
    Mar 21, 2012
    Messages:
    436
    Likes Received:
    65
    [Aug 4, 2012]
    Get the work done, get the albour bill thern hit them with a small claims court action for the charges they won't cover, under the SoGA, also speak to trading standards.
    #22
  24. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 4, 2012]
    Cheers Gov

    Sailo, i meant to say urs does look a bit black, so I would check the colour of the fuel in the filter pot, check above photo as mine was very black and you can smell the oil, also did you solve your leak in the drivers floor? i have the same but its not the door and the roof seems totally dry, almost like bottom of screen of top of wing as runs out from door seal next to fuse box :/
    #23
  25. SAiLO
    Offline

    SAiLO Enthusiast VCDS Map User

    Joined:
    May 7, 2009
    Messages:
    937
    Likes Received:
    33
    [Aug 5, 2012]
    The fuel was a bit dirty, could not smell any oil but it could have been due to the very stong smell of diesel.

    As for the leak - it never reocurred.
    #24
  26. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 8, 2012]
    Got car back today, they fitted new tandem pump, fuel filter, cleaned tank and ran 2 fuel line cleaners through, aaaaaaannnnddddd...

    Its just the same :no:

    The bloke has told me to run it on good quality fuel for a couple of weeks and this should cure things, I am not 100% convinced but a bloke at another garage did say the same thing, maybe one of you could advise?

    So it starts fine, smooth idle, ok upto about 3rd and then we get this hesitation, noticed it do it about 3k rpm tonight in 4th, almost like, pulls for a second, holds back for a second, pulls for a second, holds back for a second...

    At least the pump is done and no oil in fuel anymore.

    Injectors done in January and Audi themselves plus another place with us in car had laptop going and all looked good on all injectors and no faults shown.

    As always, comments welcome :icon_thumright:
    #25
  27. max69vk
    Offline

    max69vk Active Member

    Joined:
    Apr 3, 2012
    Messages:
    760
    Likes Received:
    43
    [Aug 9, 2012]
    It will take a couple of tanks to clear all of the lines out properly (had the same issue with mine), dont be afraid to give the car a good spanking when its warmed up either, the oily fuel will have deposited a film of nasty cack all over the sensors on the exhaust side of the system & untill its burnt off properly it can create a few issues with the sensor readings that are fed back to the ECU.
    #26
    makem3 likes this.
  28. Cromarty32
    Offline

    Cromarty32 New Member

    Joined:
    Jun 5, 2012
    Messages:
    2
    Likes Received:
    0
    [Aug 9, 2012]
    I would also pull the lift pump in the fuel tank and make sure it is clean - there is a fine mesh that can block up. It is not a hard job to do.

    Cheers

    Paul
    #27
  29. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 9, 2012]
    Thanks lads, thats put my mind at rest a bit!

    I thought with the 2 lots of cleaner they ran through it should all be clear, maybe not then.

    They are supposed to have cleaned the inside of the tank out, how do you get the back seat out?!

    I can then remove the pump and check the mesh you said about :)

    Still cant get my head around why it just hesitates at certain rpm but fingers crossed lots of Shell and BP and it could be ok!
    #28
  30. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 10, 2012]
    Dare I say, it pulled like a train constantly in 3rd off the slip road this morning to about 4500 rpm, almost took me by surprise :)

    Still like to check the lift pump so any tips on getting it n seat out much appreciated

    also is there any fuel additives its worth me putting in?

    Cheers!
    #29
  31. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 15, 2012]
    Hi guys!

    Bit of a massive update on this one, had a really good chat with the previous owner, apparently this flat spot n hesitation has been there from new!

    Went into Audi many times but they could never identify the fault so she gave up!

    Soooooo, what are the chances Audi UK would look into this to get sorted FOC etc.....?

    What is best way to go forward?

    Spose to be going back into Caragiant Friday for that n roof to be fixed so any help or advice much appreciated

    Thanks

    CB
    #30
  32. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Aug 22, 2012]
    Slight update...

    Took the car back Friday, got a totally different impression of the place in a good way, went down the road with the technician to show him the hesitation one second on, one second off etc... pointed out the water leaking point where coming in and also the drivers electric window that occasionaly seemed to keep trying to do its self up.

    Asked his opinion, leak he thought could be the drain holes blocked, hesitation first said fuel filter but explained about the tandem pump being done etc... and window he wasnt too sure.

    Had a couple of calls to keep me informed and today the update, they are waiting on some parts :-

    New windscreen
    New drivers window mechanism and motor, believe these come as one?
    New Turbo
    New oil feed and return pipes
    New oil filter
    New air filter
    New EGR gasket
    New DPF clamp
    Doing a DPF regeneration

    I asked about the oil filter as apparenty they done one before, I had one done at Audi with the service so this is the 3rd in a month! but he said in case of metal bits from the turbo getting into the oil and air system this is there policy. The screen was badly fitted so lets hope thats the leak problem so makes sense and window is what I thought.

    Thats got to be a couple of grands worth of bits plus all the fitting time so im pleased to hear this.

    Lets just hope this gets it sorted

    Shall post again when I hear :readit:

    Cheers

    CB
    #31
  33. Cossie_boy
    Offline

    Cossie_boy Member

    Joined:
    Mar 29, 2007
    Messages:
    472
    Likes Received:
    3
    [Sep 3, 2012]
    Finally!

    Got my car back today

    It turns out someone had tried to map it before but not done correctly so was overboosting, added to that the boost pressure solenoid was fault.

    The garage have mapped it now and fitted the new solenoid and all seems fine, drives much better through the gears, its a job to say as only drove it 15 minutes home stuck behind slow peoplr, grrrr, but it could actually feel a little less power in 3/4th but if it was an attempt at a harsh map maybe why.

    Still ill give it a few days.

    So if anyone else has had symptoms same as I had hopefully this thread might help you!

    Cheers for all input

    CB
    #32
  34. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Mar 22, 2013]
    Hi all,
    I had my car in at Audi today, as some of you know I've been suffering with hard starts / poor cold starting that gives a 15-20 secs jerky feel, quite scsry until she settles down with a light rev to 2000 rpm.

    I've also had a judder that appears when in high gears and at low revs, the car judders quite violently and I've been advised to replace the in tank fuel pump at over £550 by Audi
    This can be driven around / avoided and rather than try to push through it, I've always came off the gas and changed down, no issues.

    Well, with no other recomendations, I decided to try changing the fuel filter and also the glow plugs to see what effect if any that would have, couldn't hurt so lets see......

    Please see glow plugs detail below...

    NGK CZ301 7V K6Z8C
    VW AG N10579803

    [​IMG]

    [​IMG]


    I'm no expert on glow plugs but having read a lot about them, they look to be an item that aren't either necessarily good or bad, but they weaken and lose their effectiveness over time. At over 101k miles perhaps mine are due for replacement I thought, so lets see....

    Anyone with any glow plug knowledge or experience please feel free to chime in and advise what looks to be good or bad in the pics above, it could be quite helpful for others.

    The other item was the fuel filter.

    My car is looked after and anything she needs she pretty much gets. Audi recomend filter filters be changed at 40k miles
    I used to cover stellar miles, mainly motorway and around 50k - 70k per year, this has now changed to around 10k-15k and mostly stop/ start around town.

    My last filter was changed at 79583 miles and I'm currently at a little over 101k miles, so its done just under 22k miles, so should be good right?
    WRONG!!

    Mines was BLACK and contaminated with oil

    I asked Audi to keep the old fuel filter for me, but they didn't, they did one better and made me a video to share with you all showing the fuel that came out.

    See link below....

    You will need a pin to view, please use the following bearing in mind its case sensitive
    ec3cf76e

    Click here


    You can clearly see the black covering of oil in there.

    I haven't had any dodgy fill ups as far as I'm aware? I used to use Tesco fuels, but changed some time ago ( around 9 months ) and now only use Shell Vpower diesel


    Driving home from the dealers I noticed instantly a huge improvement in pulling power, she was ready n eager all good to go, pulling like a train, always a good sign.

    I did try and check several times for the jerky / judder, lumpiness and it seems to have disappeared . It may be too early to tell so I will watch for any signs of this and report back as necessary over the coming days / weeks / months.

    As for the glow plugs?

    I'm not 100% sure if they've made a difference tbh.......Again, I'll check and report back on this

    At a cost of £265.93 its all good as far as I'm concerned at the moment and money well spent.
    Thanks Stirling Audi

    Audi advise that there may be an issue either with my injectors / tandem fuel pump that could be causing the oily fuel as seen in the filter and I know thats £££ to fix........I'll be doing further checks.

    The thing is I actually had all 4 injectors and the tandem pump replaced under warranty some time ago in 2009 due to issues I was having at that time. Should these need doing again at any point and as a customer who has bought the car from new, had all service and warranty work done there, also own a Passat I'll be speaking to customer services and looking for a major contribution, if required.

    Hope this post is useful and helps someone else

    Thanks

    Jim
    #33
  35. JimC64
    Offline

    JimC64 Active Member

    Joined:
    Apr 22, 2009
    Messages:
    244
    Likes Received:
    28
    [Mar 25, 2013]
    I already change the fuel filter at around 20k ( half what Audi recomends ) but its something I will be keeping an eye on and changing, perhaps even sooner, For the sake of a few ££ its really good insurance I reckon.

    The tandem pump scenario is another issue - in late 2009 under warranty I had all 4 injectors replaced as well as a new tandem pump. If this fails again, along with the many other reported cases on this and other sites, suffice to say I won't be happy. I can see one irate owner calling customer services adnd looking for SERIOUS goodwill contribution, but here's hoping we don't get into that situation.

    I still think I'm a little under powered though although the above issues seem to be resolved for the moment.

    So.....perhaps you're right about a split intercooler / boost leak somewhere?
    I used to be able to really give her some beans and she'd respond getting up into 3 figures quite easily, now it seems a struggle!

    I'm looking at and checking into the tandem pump / lift pump, intercooler and or turbo, perhaps even the MAP / MAF....who knows?

    Something somewhere is still outta tolerance, but no codes being shown so no help there.
    #34
  36. theo289
    Offline

    theo289 Member

    Joined:
    Oct 31, 2012
    Messages:
    250
    Likes Received:
    10
    [Jul 10, 2013]
    Hi alAllan having the same issues with my 170. Did anyone find out what the issue was?
    #35
  37. MyMateDaveDJ
    Offline

    MyMateDaveDJ New Member

    Joined:
    Jun 7, 2013
    Messages:
    22
    Likes Received:
    1
    [Jul 24, 2013]
    Im in a similar situation with a car I've purchased and found this thread really useful, how's the car running now a year on?
    #36
  38. theo289
    Offline

    theo289 Member

    Joined:
    Oct 31, 2012
    Messages:
    250
    Likes Received:
    10
    [Jul 26, 2013]
    Has your car had a remap?
    #37

Share This Page