1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Strange cnok from front right side..

Discussion in 'A4/S4 forum(B5 Chassis)' started by kninio, Dec 26, 2007.

  1. kninio
    Offline

    kninio Member

    Joined:
    Oct 12, 2005
    Messages:
    96
    Likes Received:
    0
    I have a strange cnoking from the right side front even i have all control arms replace by brand new kit 2 months a go , and the sound come when i accelarete and some times when i slow down , its like something banging.. , could be the strut mount ? or what else can make those noises?

    any help will be appreciated!
    #1
  2. Siena
    Offline

    Siena Active Member

    Joined:
    Oct 28, 2007
    Messages:
    2,626
    Likes Received:
    3
    Gearbox or engine mounts?
    #2
  3. kninio
    Offline

    kninio Member

    Joined:
    Oct 12, 2005
    Messages:
    96
    Likes Received:
    0
    gearbox mounts changed too , 3 months ago , same with engine one... , could be the strut mounts?
    #3
  4. Siena
    Offline

    Siena Active Member

    Joined:
    Oct 28, 2007
    Messages:
    2,626
    Likes Received:
    3
    Yes, very possible top mounts are worn.

    Worn ARB link bars can also cause knocking!
    #4
  5. kninio
    Offline

    kninio Member

    Joined:
    Oct 12, 2005
    Messages:
    96
    Likes Received:
    0
    arb link bars changed with the control arms :) i changed all at once , what is still worn the front engine stop mount , but i already bought it and i will change , but the sound is not coming from it i think cos i hear it from the right side.

    about the strut mount is they comon to wear? what wear on them? maybe they were tired since long and i didnt know that? , how can i inspect it?
    #5
  6. andybnwc
    Offline

    andybnwc Member

    Joined:
    Jun 29, 2007
    Messages:
    752
    Likes Received:
    0
    ive got a similar knock when on of gas in a right hand bend but got more important things to fix first lol
    #6
  7. kninio
    Offline

    kninio Member

    Joined:
    Oct 12, 2005
    Messages:
    96
    Likes Received:
    0
    aha, but you didnt figure it out yet?, does the strut mount comon to fail and make such a noise?
    #7
  8. OnTheJazz
    Offline

    OnTheJazz Member

    Joined:
    Feb 1, 2007
    Messages:
    37
    Likes Received:
    0
    Hi kninio, where did you get your kit from?

    I puchaced a kit from ebay about 6months ago, fitted it up then about 2months after fittinf a knock could be heard from the front driverside.
    it turned out that the washer had boken and fallen out, this was the new bolt and washer i got with the kit! i torqued all bolts to specified torque settings, must just have been a **** washer.
    i put the original bolt back in and its been fine since, have a look, could be the same thing
    #8
  9. kninio
    Offline

    kninio Member

    Joined:
    Oct 12, 2005
    Messages:
    96
    Likes Received:
    0
    i bought them from lemforder dealer in lebanon , no i figure it out its really the strunt mount cos when i am turning the sound come on , otherwise everything is fine :) , i will buy pair of strut mount and change them! , i had a rear end unstable in my car and today i changed the rear shock mounts and u cant believe what difference it made! so propably the fronts is also wear so i will change and inform you!

    cheers all!
    #9

Share This Page