1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stereo wiring mess on my02 A3 8L

5am Dec 26, 2012

  1. 5am

    5am Member

    48
    0
    6
    So there is the standard connectors:

    [​IMG]

    Then there is this unknown box - what is this an aerial amplifier:

    [​IMG]

    The box has there connectors coming out of it:

    [​IMG]

    Then it come with this loom as well aftermarket im guessing:

    [​IMG]

    And this is the loom from my sony stereo that i want to fit:

    [​IMG]

    Soooooooo, how does all this go together for my sony HU to work? What is that box? Is it necessary?

    Have i got everything i need here to make my HU work?

    Thanks for the help.

    Sam.
     
  2. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    Well that box is iirc an alpine cd changer adapter to work with existing audi head unit.

    Which head unit are you wanting to fit so can check connectivity, as it may need permanent power, plus possibility of manual on/off or via ignition by tapping fusebox feed or some canbus network connectivity for the on/off signals.

    Andy may know more on this, sure he'll pop in at some point.
     
  3. AR-rkon

    AR-rkon Mod back in a "B" Staff Member Moderator Regional Rep Team V6 Team Silver Audi A6 Audi A4 Audi Avant Owner Group

    1,911
    164
    63
    It looks as though you only have 4 wires in the brown connector, which suggests to me, that you have a half amplified system. That said, it also looks as though that "other" aftermarket lead (Picture 4), is an adaptor for said system.

    So, best plan of attack would be to connect that aftermarket lead into the car, and add the stereo wiring to the end. you should then have full sound from all four corners, without it, you would only have sound from the front two speakers.

    Hope this helps. :icon_thumright:
     
  4. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    Yeah I'd agree with that aswell, now the princess is out of my hands lol, had time to study it more, that aftermarket adapter doesnt appear to have any canbus wires to connect through either, so again need radio model to see what the crack is on that score, but I'd follow what arrkon suggests.
     
  5. AR-rkon

    AR-rkon Mod back in a "B" Staff Member Moderator Regional Rep Team V6 Team Silver Audi A6 Audi A4 Audi Avant Owner Group

    1,911
    164
    63
    I like to think I know what I'm talking about Nigel :lmfao:

    I think an 02 8L would only have a K-line. Even so, iirc, the adaptor is missing a pin in that cavity anyhow :) just thinking about the vag com backfeed issue :)

    CANh and CANl would be in the middle connector of the mini ISO's (green)
     
  6. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    It does have can H/L, check car connectors, orange wires.
     
  7. AR-rkon

    AR-rkon Mod back in a "B" Staff Member Moderator Regional Rep Team V6 Team Silver Audi A6 Audi A4 Audi Avant Owner Group

    1,911
    164
    63
    Ahh, cack.... Missed them haha. Nice one Nigel :D
     
  8. 5am

    5am Member

    48
    0
    6
    The previous owner of my car told me that he took out an Alpine system.

    So i take it i wont need the box in pic 2 and connector in pic 3?

    I want to put in a sony HU, i think its: a Sony MEX-BT3600U (just off the top of my head need to check it in my garage).

    Connectors wise: Have i got everything i need to make the HU work? What else will i need?

    Thanks.
     
    Last edited: Jan 2, 2013
  9. AR-rkon

    AR-rkon Mod back in a "B" Staff Member Moderator Regional Rep Team V6 Team Silver Audi A6 Audi A4 Audi Avant Owner Group

    1,911
    164
    63
    Correct, should only need the connector in pic 4, your Sony should plumb in on the end, should then have music, happy days.

    Worst case, if the stereo doesn't store the stations, swap the yellow and red leads over. Simples :)
     
  10. 5am

    5am Member

    48
    0
    6
    Thanks for all your help. Got a working stereo now after repinning.

    The stereo only comes on if the car is running. I want it to run a soon as i turn the key when i get the dash lights or i dont even mind it permanetly live even if the key is not in. How can i achieve this?
     
  11. 5am

    5am Member

    48
    0
    6
    Any ideas how i can get the stereo to work without having the engine running?

    Can it have a permanent live? If so, where's the best place to get the perm live from?
     
  12. NHN

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    29,272
    1,685
    113
    You mean without key in at all or just ignition switched on, but no engine running, cause an ignition switched feed would be sufficient.
     
  13. 5am

    5am Member

    48
    0
    6
    Dont mind either, at the moment the stereo only works if the engine is running.
     
  14. AndyMac

    AndyMac Moderator Staff Member Moderator

    9,833
    45
    38
    You just need to connect both yellow and red leads from the Sony together then both of them connected to the permanent live on the Audi black iSO connector. This will keep the hu live so you need to turn it on/off manually. Or you can run a proper accessory feed from the fuse box, fuse radio s-kont this will keep the hu live until you pull the keys out.
     

Share This Page