1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

stereo wiring diagram

Discussion in 'A4/S4 forum(B5 Chassis)' started by sherry, Jun 25, 2008.

  1. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Hi guys.

    My a4 came without a stereo and i am now going to fit a new one. Is there a wiring diagram or would anyone know where i can get a harness to fit a JVC KD-AVX33 stereo. This stereo has a smaller plug than the standard jvc harness. Not having much joy finding one so i was just going to wire it myself if i had a diagram.

    Cheers
    #1
  2. Ads

    Ads

    [Sep 17, 2014]

  3. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,569
    Likes Received:
    313
    [Jun 25, 2008]
    the A4 uses a standard ISO wiring plug for the stereo... although on mine there was no ignition live feed and i had to add one via a relay from the central electrics panel under the dash

    the ISO -> JVC plug lead you can probably find on ebay
    #2
  4. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    #3
  5. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Thanks guys.

    I have tried fleebay but my stereo takes a smaller connector which i cant find on fleebay.
    #4
  6. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    Post a pic of your connectors so we can see if we can help further, andymac is the man to ask, try asking him for help.
    #5
  7. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Thanks again m8

    here is a pic of my cars wiring.

    [​IMG]


    Here is a pic of the connector that goes into my stereo

    [​IMG]
    #6
  8. brendan
    Offline

    brendan 98 A4 1.8SE

    Joined:
    May 31, 2008
    Messages:
    137
    Likes Received:
    0
    [Jun 25, 2008]
    what's on the other end of that? just bare wires? did you buy the radio new or 2nd hand? i'd be amazed if it came new without ISO connectors somewhere in the box.
    #7
  9. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    No worries, well the top 2 look like standard ISO I think & bottom one is strange as havnt seen that before on an audi, Andymac if you are on here could you help them out?

    If andy isnt on then find him on the ice forum & send him a pm to comment on this thread.

    I'll look about for that connector.
    #8
  10. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Hi Brendan

    thanks for the reply.

    i bought the stereo brand new. It is a JVC KD-AVX33 and it has bare wires at the other end of the connector.

    Also i got the stereo through ebay and it was imported from Canada or America i think.
    #9
  11. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    well speakers are on the orangey/brown connector so no amp in boot then, all you need are the wiring diags which i believe you can google for & then cut & join, some wires are probably for kline diag to the DIS aswell which wont work I dont think with the JVC anyway, so all you really need is speakers, antenna, ground, live/switched live etc basic wires, maybe illumination wire aswell, but apart from that its fairly simple, I'll try & find the wiring diags for that connector, strange as on my 99 S3 it has the standard connectors so adapter harnesses fitted easily, surely the jvc had a proper plug/socket harness with no?
    #10
  12. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    #11
  13. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    30
    [Jun 25, 2008]
    The brown connector is indeed the speaker connections but never seen an A4 where all the speakers are wired at the HU. As standard you normally have only the fronts on that connector and then the rears wired to an amp bolted to the left rear speaker.
    Anyway it makes your life a lot easier with all the connections wired.
    You need to buy a male ISO speaker harness, and a male power harness (£2.99 each from Halfords or Maplins). Then connect up as follows:
    Power ISO
    Black wire on Pioneer to brown wire on Audi loom
    Yellow & Red wires on Pioneer to red/blue wire on Audi loom (the one above the brown earth)
    You don't have a switched live on that loom, so you'll have to connect both feeds on the Pioneer to the perm live & rely on turning the HU on/off manually or wire in a switched live from the fusebox. If you do this then the yellow wire goes to perm live and red wire to the new ignition on live.
    Speaker connection:
    The top row is +ve, bottom row -ve.
    The far left pair (top & bottom) are left rears
    The next pair in are left fronts
    The next pair right fronts
    The far right pair (top & bottom) are right rears
    these need to connect to the equivalent white, grey, green & purple/pink wires on the Pioneer.
    I'd solder the connections and use heashrink to insulate them, otherwise you'll have a host of terminal blocks or connectors behind the HU and you're bound to get issues as they will get squashed/tugged when you refit everything.
    #12
  14. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 25, 2008]
    I told yer, Andy is the man & he would be along any second, lol.

    Dont talk to me about Maplins, god dropped £100 on relays, pcb's etc other day, luckily I dont need it all, but better safe than sorry huh, lol.

    I dont think they have Maplins in Italy so looks like a PO Box forwarding when living in Italy, greatttttttttttt as Tony says.
    #13
  15. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Thank you so much guys.

    I already have a iso wiring loom that i bought for the stereo but it didnt fit.

    i will cut it and wire it up as andymac describes.
    nigelhobden you where correct m8. Andy is the man :beerchug:

    :hi:
    #14
  16. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 25, 2008]
    Hi Guys.

    I just thought i would update you with what i have done.

    I carried out anymac's instructions and it work first time :arco:

    Thank you andymac :anbet:
    #15
  17. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    30
    [Jun 25, 2008]
    Fast work, nice one!
    #16
  18. NHN
    Offline

    NHN Retrofitter - Audi - VW - Skoda - Seat Site Sponsor VCDS Map User

    Joined:
    Jan 14, 2008
    Messages:
    27,319
    Likes Received:
    1,229
    [Jun 26, 2008]
    I was gonna say feck me that was quick.
    #17
  19. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 26, 2008]
    LOL Cheers guys

    :beerchug:
    #18
  20. andybnwc
    Offline

    andybnwc Member

    Joined:
    Jun 29, 2007
    Messages:
    752
    Likes Received:
    0
    [Jun 26, 2008]
    did you manage the switched feed ok? did you earth the parking brake feed for image?
    #19
  21. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,569
    Likes Received:
    313
    [Jun 26, 2008]
    i created a switched live for mine by taking a feed from the 75X pin on the central electrics and wiring that to the coil of a std 4 pin relay. I powered the main switch of the relay from the normal stereo permenant live feed so its still protected by the normal stereo fuse.
    it all fits nicely behind the stereo
    #20
  22. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 26, 2008]
    Hi.

    I haven't done the parking brake feed yet. all i did was join the switched feed along with the live just like andymac advised.
    #21
  23. andybnwc
    Offline

    andybnwc Member

    Joined:
    Jun 29, 2007
    Messages:
    752
    Likes Received:
    0
    [Jun 26, 2008]
    i would defo run down to the bus bar connect ring terminal to the closest terminal to the stereo side, just join the parking brake cable to the black earth cable on your loom
    #22
  24. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 27, 2008]
    Thank you andybnwc

    would you have any more info on how to do what you recommended?

    I have no idea what the bus bar connect ring terminal is :uhm:

    :beerchug:
    #23
  25. andybnwc
    Offline

    andybnwc Member

    Joined:
    Jun 29, 2007
    Messages:
    752
    Likes Received:
    0
    [Jun 28, 2008]
    look under the steering column near the row of relays you will see some large terminals some yellow some red with large ring connectors attatched i think its the x75 one on left but just check with a multi meter if unsure! hope this helps

    you have to remove panel under steering column 8mm bolts with clips on top edge, pop of the fuse box cover to se 2 more 8mm bolts
    #24
  26. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 28, 2008]
    Thank you again andybnwc

    Can i confirm that i join the handbrake cable to the black wire on the loom at the back of the stereo and do i connect the yellow wire with the inline fuse to the ring connector? Should this ring connector be +12v?

    :beerchug:
    #25
  27. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 28, 2008]
    Hi guys.

    I went out and wired up the stereo as described by andybnwc and it worked first time.

    I didn't realise that there is a big label on the the ring terminals and a yellow one saying X75. LOL it couldn't have been any easier for me.

    Now the stereo goes of with the ignition and i can watch dvd's. Obviously not when driving though :laugh:.

    You guys on this site are the best.

    A BIG thank you again.

    :beerchug:

    :applaus:
    #26
  28. andybnwc
    Offline

    andybnwc Member

    Joined:
    Jun 29, 2007
    Messages:
    752
    Likes Received:
    0
    [Jun 28, 2008]
    no worries
    #27
  29. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 28, 2008]
    Another quick question guys.

    i have notticed that i lose my settings such a time ect on my stereo when i turn the car off.

    Is this normal and is there any way to have it so i dont loose them?
    #28
  30. Broken Byzan
    Offline

    Broken Byzan Photographic Moderator Staff Member Moderator VCDS Map User

    Joined:
    Apr 26, 2004
    Messages:
    12,597
    Likes Received:
    273
    [Jun 28, 2008]
    do you have it wired to a prem live? I had to swap the perm live and ignition live around on my avx1
    #29
  31. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 28, 2008]
    hi byzan.
    thanks for the reply
    i will give it a try.
    does that mean i will connect my yellow wire that is on to the x75 ring terminal to the black wire on the iso cable of the car and vice versa?
    #30
  32. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    30
    [Jun 28, 2008]
    No, just swap the red and yellow cables over
    #31
  33. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 28, 2008]
    oh.

    i understand now.

    :beerchug:
    #32
  34. sherry
    Offline

    sherry Member

    Joined:
    Apr 4, 2008
    Messages:
    171
    Likes Received:
    0
    [Jun 29, 2008]
    Got it all done now guys :yahoo:

    Thanks again

    :beerchug:
    #33

Share This Page