1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Stereo replacement problem

Discussion in 'In-Car Entertainment' started by boroian, Jun 10, 2011.

  1. boroian
    Offline

    boroian New Member

    Joined:
    Jun 10, 2011
    Messages:
    4
    Likes Received:
    0
    [Jun 10, 2011]
    Hi,

    I'm having real problems trying to replace my Concert headunit with an aftermarket Sony headunit.

    I've tried the standard harness adapters that are out there on the web but have had not success so far, haven't even got power to the headunit as yet!

    I'm not exactly experienced with this kind of thing, but have managed to fit the same head unit into a BMW which I've just sold for an A4.

    I have a couple of photos here to show the wiring, any advice would be very much appreciated.

    [​IMG]

    [​IMG]

    Thanks.
    #1
  2. Ads

    Ads

    [Dec 26, 2014]

  3. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Jun 10, 2011]
    Can't see anything with those miniscule pics, but chances are you have a CANBUS Audi (2000+)
    So you don't have the two 12v feeds needed to power the HU, perm live and ignition live
    So you either need to connect the yellow feed from the HU to the red one so that they both go to the perm live on the Audi loom, or you need to wire in an ignition on feed from the fusebox.
    #2
  4. boroian
    Offline

    boroian New Member

    Joined:
    Jun 10, 2011
    Messages:
    4
    Likes Received:
    0
    [Jun 10, 2011]
    Thanks Andy, not sure what happened with the photos, these should be better.

    My audi is 2004, are you suggesting that I need to patch the yellow wire on the harness into the red wire to get voltage into the head unit?

    [​IMG]

    [​IMG]
    #3
  5. AndyMac
    Offline

    AndyMac Moderator Staff Member Moderator

    Joined:
    Jun 10, 2003
    Messages:
    9,833
    Likes Received:
    32
    [Jun 10, 2011]
    Yes everything else looks correct
    #4
  6. boroian
    Offline

    boroian New Member

    Joined:
    Jun 10, 2011
    Messages:
    4
    Likes Received:
    0
    [Jun 10, 2011]
    I've just been and tried this out, success :salute: thanks for the help, much appreciated. Thank you.
    #5

Share This Page