1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

stereo and factory sat nav not working after battery swap

Discussion in 'A3/S3/Sportback (8P Chassis)' started by clashcityrocker, Nov 26, 2012.

  1. clashcityrocker
    Offline

    clashcityrocker New Member

    Joined:
    Nov 26, 2012
    Messages:
    3
    Likes Received:
    0
    [Nov 26, 2012]
    hi guys, any help much appreciated.
    had to fit a new battery y/day after the old one was totally flat, wouldn't even jump lead start.
    after fitting battery, the stereo and the sat nav will not start up, stereo doesn't even say SAFE.
    have checked both fuses and they're fine so now i'm stuck.
    have checked all other electrical functions and they're all working fine.
    its the Audi Concert stereo and its the direction / voice sat nav with the controls on the centre console and the display between the clocks. panel works when i run test sequence but is blank otherwise, i.e. shows no radio / CD functions.
    can you advise / help me please?
    car is a 2004 A3 3dr 2.0FSi SE auto
    #1
  2. Ads

    Ads

    [Sep 23, 2014]

  3. OCD-A3
    Offline

    OCD-A3 Member

    Joined:
    Jul 17, 2011
    Messages:
    113
    Likes Received:
    10
    [Nov 26, 2012]
    Not to be condescending, but did you try the power button? Normally the stereo will power on with ignition if it was on when you last shut the ignition off, but when you pull the battery it "forgets" and goes back to default settings (which leave the stereo off until you press the power button.)
    #2
  4. Sidhu88
    Offline

    Sidhu88 Active Member

    Joined:
    Jan 31, 2012
    Messages:
    797
    Likes Received:
    74
    [Nov 26, 2012]
    If the above doesnt work tey disconnecting the battery for 30 mins or so to allow the ecu to reset again and then reconnect. Worked a few times on some audis
    #3
    clashcityrocker likes this.
  5. clashcityrocker
    Offline

    clashcityrocker New Member

    Joined:
    Nov 26, 2012
    Messages:
    3
    Likes Received:
    0
    [Nov 30, 2012]
    cheers for that mate, i've ordered some keys to remove the head unit so i can check the in-line fuse. hopefully, it will be that and a new fuse will sort it. if not i'll try your tip.
    #4
  6. clashcityrocker
    Offline

    clashcityrocker New Member

    Joined:
    Nov 26, 2012
    Messages:
    3
    Likes Received:
    0
    [Dec 4, 2012]
    new fuse fitted and stereo working fine, however i can't get sat-nav to work but i can live without that, it wasn't a brill system anyway.
    #5

Share This Page