1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Steaming?

MBK Dec 18, 2012

  1. MBK

    MBK Well-Known Member

    1,161
    1,111
    113
    Seasons greetings all, twice I've noticed some steam escaping from the front of my RS3 for about a minute after stopping the engine. First time was after a long run on an extremely wet day and the second after a short run in heavy traffic on a cold morning. The car is running perfectly and there are no other signs of a problem. I have seen similar things reported by TTRS owners so I'm not too concerned, it's just a bit odd to see it happen.

    Has anyone else noticed anything similar and is there a fix at the dealers I should be aware of?
     
  2. jerseypaul

    jerseypaul Member

    241
    29
    18
    Haven't noticed any from the front of the car.
    Plenty from the brakes though.

    :icon_thumright:
     
  3. Kohaku

    Kohaku Member

    196
    27
    16
    Yeah. think twice,as you say when it was wet.

    Probably a free mod,like the squealling brakes.Only start to get worried if you see flames.
     
    A_C4mby and robbiemac like this.
  4. monkeyboy_marcus

    monkeyboy_marcus Active Member

    353
    137
    43
    He mentioned steam, not squeal!
     
  5. robbiemac

    robbiemac 'S' Button engaged....

    733
    388
    18
    Free mod........ Classic Kohaku, classic.
    Mine's been steaming for ages, kinda like it....... Fire breathing dragon and all that.
    Looks serious on a frosty morning.......
     
  6. CarrG

    CarrG Active Member

    261
    36
    28
    Yes I've noticed that on cold damp days.

    Not as bad as my modded Cupra was tho.
     
  7. 45bvtc

    45bvtc Well-Known Member Supporter Team Daytona Gold Supporter Team Cornflower Blue Team Sahara Silver Audi RS3 Audi TT Audi A1

    4,056
    6,334
    113
    Sounds to me like condensate loss from the air-conditioning system, but first make sure you're not loosing engine-coolant from the water make-up bottle/container. If you are loosing engine-coolant then I'd get the car into Audi and have the engine-cooling system pressure tested.

    However, if you are not loosing engine-coolant then, and I know it may be difficult, but try and collect some of the steam (I'll not suggest a method as someone's bound to say something, but I'd use the palm of my hand, oh dear...) and taste-test it! If it's condensate then it'll have no taste at all - but that depends on what you've had on your hand, of course.

    Usually, if it is condensate, all you would see is a small pool of clear water/condensate under the front of the car and lying on the garage floor; I've seen it from all of my Audi cars: current RS3 and 2.0TT, and previous 3.2TT, 1.6A2, and 1.8S3.

    But again, if there is an unusual taste then I'd get the car into Audi and have the engine-cooling system pressure tested.

    Enjoy the taste-test...

     
  8. MBK

    MBK Well-Known Member

    1,161
    1,111
    113
    Thanks all, it's reassuring to know it's nothing then.

    I'm glad to say there is no loss engine coolant and I think I'll give the taste test a miss! :yum:
     
  9. HeliRS3

    HeliRS3 New Member

    2
    0
    1
    Hi there,

    Mine does this too - it's simply water evaporating off the extremely hot radiators (look into and behind your grill) when surface water on the road or raining heavily, post engine shut down. This happens on most high performance cars with front mounted radiators (and some none performance). I like it, some don't...like a bull snorting before it charges! :)
     
  10. robbiemac

    robbiemac 'S' Button engaged....

    733
    388
    18
    [​IMG]

    smoking......... ;-)
     

Share This Page