1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

squeky front suspension

Discussion in 'A4/S4 forum(B5 Chassis)' started by misledyouth, Aug 15, 2003.

  1. misledyouth
    Offline

    misledyouth New Member

    Joined:
    Aug 15, 2003
    Messages:
    1
    Likes Received:
    0
    i have a crazy squek in my fron passenger side when i go over bumps. Another car at the lot where i bought it from had the same problem. Has any one heard of this or know the fix. Almost sounds like it's coming from the upper control arm, but that is just a guess.

    thanks

    new audi owner jesse
    #1
  2. kurtdaniel
    Offline

    kurtdaniel New Member

    Joined:
    Aug 7, 2007
    Messages:
    18
    Likes Received:
    0
    I had the same problem. My first guess was a worn out sway bar bushings. But Ive read a few thread about this, and theyre saying that it has something to do with the caliper.
    #2
  3. Z82
    Offline

    Z82 Member

    Joined:
    Apr 9, 2006
    Messages:
    454
    Likes Received:
    0
    I had it on rear when I first bought the car, the previous owner told me it was the anti-roll bar bushes. I got these changed and it made no difference. I had several people look at it with no joy then got my mechanic to put it up a ramp for a good fondle and it turned out to be a broken rear spring.
    #3
  4. g60leigh
    Offline

    g60leigh Well-Known Member

    Joined:
    Jun 16, 2007
    Messages:
    1,408
    Likes Received:
    126
    I had a similar thing when I fitted my coilovers, I had replaced ALL of the bushes at the same time.
    turned out to be the shocker, sprayed the shaft with some brake cleaner then some spray lube (Duck Oil) and sorted it straight out,
    probably not that on yours, but you never know and easy enough to try
    #4
  5. Lee Goodall
    Offline

    Lee Goodall ..got my head together!

    Joined:
    Oct 22, 2007
    Messages:
    2,231
    Likes Received:
    1
    An easy way to find the problem is to systematically WD40/lube each joint/bush then test drive until the noise has gone it'll most probably come back again but you'll know what's causing it.
    #5
  6. docurley
    Offline

    docurley Moderator Staff Member Moderator

    Joined:
    Dec 12, 2003
    Messages:
    3,859
    Likes Received:
    25
    Had it on my old 2.8 A4 after have spring fitted turned out to be one of the control arms in the end.
    #6
  7. Nilz
    Offline

    Nilz Defo worth the wait :)

    Joined:
    Apr 9, 2006
    Messages:
    10,217
    Likes Received:
    389
    I have this on my S3, i have changed the ARB bushes and after a few days the noise came back again, someone else has advised it may be the top mounts on the suspension, it only comes from the front, but I havent had a chance to look at the top mounts, do you think it would be worth wd40'ing them???
    #7

Share This Page