1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Speedo Issue

Discussion in 'A4/S4 forum(B5 Chassis)' started by DaveGT, Oct 1, 2013.

  1. DaveGT
    Offline

    DaveGT New Member

    Joined:
    Dec 10, 2012
    Messages:
    20
    Likes Received:
    0
    [Oct 1, 2013]
    Hi guys. I've recently got a b5 A4 2.5 TDi with the AFB V6 engine and 6-speed box. It's front wheel drive if that makes any difference. I've got an issue with the speedo whereby it intermittently stops working. Needle just dies back to 0 regardless of how fast I'm travelling. Only ever lasts a few seconds and then jumps back into life and works as it should. Has anyone come across this problem before or know where to start looking?
    Thanks in advance
    Dave
    #1
  2. Ads

    Ads

    [Dec 18, 2014]

  3. Chillout
    Offline

    Chillout Active Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    [Oct 1, 2013]
    Hi it could be an instrument issue or the road speed sensor I would say the best bet would be to get a scan done to point you in the right direction.
    #2
  4. DaveGT
    Offline

    DaveGT New Member

    Joined:
    Dec 10, 2012
    Messages:
    20
    Likes Received:
    0
    [Oct 2, 2013]
    I scanned it myself and it didn't throw any faults up
    #3
  5. aragorn
    Offline

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Joined:
    Jan 30, 2008
    Messages:
    15,845
    Likes Received:
    350
    [Oct 2, 2013]
    might be worth checking the plugs/wiring to the speed sensor on the gearbox? Then replacing the sensor if that doesnt show up anything?
    #4
  6. Chillout
    Offline

    Chillout Active Member

    Joined:
    Apr 4, 2013
    Messages:
    596
    Likes Received:
    48
    [Oct 2, 2013]
    Depending what diagnostic set up you used it might be worthwhile graphing the sensor for loss of signal
    #5
  7. DaveGT
    Offline

    DaveGT New Member

    Joined:
    Dec 10, 2012
    Messages:
    20
    Likes Received:
    0
    [Oct 2, 2013]
    Thanks guys. At least I know where to start now
    #6
  8. @udi A3
    Offline

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    Joined:
    May 25, 2012
    Messages:
    1,770
    Likes Received:
    175
    [Oct 2, 2013]
    Also the earthing points on the chassis for the speed senser and cluster curcuit, my a3 did the same and it was bad earths, usually previously i would condem the cluster!
    #7
  9. DaveGT
    Offline

    DaveGT New Member

    Joined:
    Dec 10, 2012
    Messages:
    20
    Likes Received:
    0
    [Oct 2, 2013]
    Thanks mate
    #8

Share This Page