1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Speedo Issue

DaveGT Oct 1, 2013

  1. DaveGT

    DaveGT New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Hi guys. I've recently got a b5 A4 2.5 TDi with the AFB V6 engine and 6-speed box. It's front wheel drive if that makes any difference. I've got an issue with the speedo whereby it intermittently stops working. Needle just dies back to 0 regardless of how fast I'm travelling. Only ever lasts a few seconds and then jumps back into life and works as it should. Has anyone come across this problem before or know where to start looking?
    Thanks in advance
    Dave
     
  2. Chillout

    Chillout Active Member

    Messages:
    607
    Likes Received:
    48
    Trophy Points:
    28
    Hi it could be an instrument issue or the road speed sensor I would say the best bet would be to get a scan done to point you in the right direction.
     
  3. DaveGT

    DaveGT New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I scanned it myself and it didn't throw any faults up
     
  4. aragorn

    aragorn "Stick a V8 in it!" Staff Member Moderator VCDS Map User

    Messages:
    17,768
    Likes Received:
    673
    Trophy Points:
    113
    might be worth checking the plugs/wiring to the speed sensor on the gearbox? Then replacing the sensor if that doesnt show up anything?
     
  5. Chillout

    Chillout Active Member

    Messages:
    607
    Likes Received:
    48
    Trophy Points:
    28
    Depending what diagnostic set up you used it might be worthwhile graphing the sensor for loss of signal
     
  6. DaveGT

    DaveGT New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thanks guys. At least I know where to start now
     
  7. @udi A3

    @udi A3 Site Sponsor Site Sponsor VCDS Map User

    Messages:
    1,768
    Likes Received:
    178
    Trophy Points:
    63
    Also the earthing points on the chassis for the speed senser and cluster curcuit, my a3 did the same and it was bad earths, usually previously i would condem the cluster!
     
  8. DaveGT

    DaveGT New Member

    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Thanks mate
     

Share This Page