1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

solid brake pedal

Discussion in 'A4/S4 forum(B5 Chassis)' started by olds_kool, May 23, 2008.

  1. olds_kool
    Offline

    olds_kool Active Member

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    got an intermittent fault with the brakes on my 99 avant, the pedal will occasionally go very hard, like when you press it with ign. off, brakes still work the pedal just doesnt travel as far as normal
    checked servo pipes and pulled pipe out it was holding pressure
    could a sticking caliper cause this? i remember advise note on m.o.t about one of calipers but cars been a bit neglected lately as my other one needed a fair bit of work
    any ideas
    #1
  2. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,570
    Likes Received:
    268
    A seized caliper will cause a solid pedal, probably one of the rears, was on mine, had to rebuild both
    #2
  3. olds_kool
    Offline

    olds_kool Active Member

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    cheers, back to the scrapyard tommorrow, disks and fluid need changing anyway
    #3
  4. Broken Byzan
    Online

    Broken Byzan Photographic Moderator Staff Member Moderator

    Joined:
    Apr 26, 2004
    Messages:
    12,570
    Likes Received:
    268
    Make sure you get alloy if you have alloy, and cast if you have cast as the hose connections are different.

    The backs are slow to bleed in my expreience so be patient with them.

    Did you get my email?
    #4
  5. olds_kool
    Offline

    olds_kool Active Member

    Joined:
    Jul 21, 2007
    Messages:
    1,072
    Likes Received:
    4
    fitted new disks and pads all round, luckily calipers were fine but one slider on rear carrier was rusted solid, had to leather it with hammer to free it, cleaned and greased it up and all seems ok, just oil leak, brake fluid, breather, engine mount, front shocks, pump timing and battery to sort out
    #5

Share This Page