1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Self Revving?

Discussion in 'A3/S3 Forum (8L Chassis)' started by shaneg, May 13, 2010.

  1. shaneg

    shaneg New Member

    Joined:
    Apr 30, 2010
    Messages:
    7
    Likes Received:
    0
    Occasionally (1 in 5 stops roughly), whilest sitting at, say traffic lights, my a3 will rev itself between its idle point and about 1.5k revs up and down until I pull away.

    Engine management light is on.

    Unfortunately I have not had a chance to get it diagnosed yet due to a busy work schedule but I would like to know what you guys think the problem maybe and a rough cost if at all possible!

    Thank you
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. JD09

    JD09 I'm not modding, I'm improving
    VCDS Map User

    Joined:
    Dec 20, 2009
    Messages:
    3,106
    Likes Received:
    43
    Would suggest it'll be difficult to diagnose without running VAGCOM, that'd be the best bet.
     
  4. DaveA3

    DaveA3 Audi A-Trizzle!

    Joined:
    Feb 25, 2010
    Messages:
    2,375
    Likes Received:
    15
    mine did this a lil bit. Turns out the throttle body just needed cleaning. get some carb cleaner and spray it in and give it a few revs. i took mine out to clean tho as it was easier to get all the **** out

    :thumbsup:
     
  5. <tuffty/>

    <tuffty/> Badger 5 Edition...Its all about the flow...
    Staff Member Moderator Audi S3

    Joined:
    Sep 14, 2008
    Messages:
    18,214
    Likes Received:
    2,402
    Sounds like a vacuum leak and a big one if its caused the CEL to come on as at a guess the idle trim will be maxed out...

    VAGCOM and block 032 will say for sure...

    Have a look at hoses coming off the bottom of the inlet mani in particular the PCV ones as I would imagine you have a big split in that...

    <tuffty/>
     
  6. Westy

    Westy Double Dark Side! Diesel & 8P

    Joined:
    Dec 2, 2008
    Messages:
    17,376
    Likes Received:
    1,013
    Also could be the clutch sensor. You'll need to get it on VCDS/Vagcom
     
  7. shaneg

    shaneg New Member

    Joined:
    Apr 30, 2010
    Messages:
    7
    Likes Received:
    0
    Thanks for the replies people, Will take a look tonight when I get home from work at the mentioned causes, if no joy will get it on diagnostics asap
     

Share This Page