1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Secondary air injection system

Discussion in 'A3/S3 Forum (8L Chassis)' started by m444ty p, Nov 27, 2009.

  1. m444ty p
    Offline

    m444ty p Member

    Joined:
    Oct 26, 2009
    Messages:
    140
    Likes Received:
    0
    Is there a step by step guide to fixing this?
    #1
  2. Andrew@A.L.D
    Online

    Andrew@A.L.D Cylinder Head Master

    Joined:
    Jun 19, 2009
    Messages:
    3,508
    Likes Received:
    355
    #2
  3. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    the whole system? what is not working on the system?
    #3
  4. m444ty p
    Offline

    m444ty p Member

    Joined:
    Oct 26, 2009
    Messages:
    140
    Likes Received:
    0
    This is the fault code my scanner gave me.

    16795 / secondary air injection system faulty flow p0411
    #4
  5. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    #5
  6. m444ty p
    Offline

    m444ty p Member

    Joined:
    Oct 26, 2009
    Messages:
    140
    Likes Received:
    0
    thanks i have no light on, just this code keeps coming back. What does this pump do? Will it slow my car up? cause any running problems?
    #6
  7. rossbrownlee
    Offline

    rossbrownlee Ross_S4

    Joined:
    Aug 16, 2009
    Messages:
    719
    Likes Received:
    0
    Have a look at this post for the effects it might have.

    I believe the secondary air inlet system is to assist in emmission control when you start up from cold.
    #7
  8. pauldazzle
    Offline

    pauldazzle Active Member

    Joined:
    Nov 11, 2009
    Messages:
    651
    Likes Received:
    34
    Yeah it only operates when the car is cold.
    #8
  9. NHN
    Offline

    NHN Modmetractor

    Joined:
    Jan 14, 2008
    Messages:
    27,226
    Likes Received:
    1,220
    Its most likely goosed if no flow detected, could have become unplugged unlikely but possible or the wiring has got damaged, the rivet mod quietens it down sometimes, but on mine a pipe from the airbox had split & it had filled up with rain water over time & it was burnt out big time & yes Ross is correct it helps the cat to get working quicker.
    #9
  10. jonny87
    Offline

    jonny87 Active Member

    Joined:
    Sep 24, 2009
    Messages:
    1,098
    Likes Received:
    3
    mine threw up a code for this pump, its not the same as what matty is getting, but seems similar, could someone just clarify what i should be looking at, the pump itself or its relay, if the relay where is it located please?
    #10

Share This Page