1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SD card not working

Discussion in 'A3/S3/Sportback (8P Chassis)' started by Young un, May 3, 2008.

  1. Young un
    Offline

    Young un Member

    Joined:
    Mar 8, 2008
    Messages:
    101
    Likes Received:
    0
    Just wondering if any could help

    Im using 256MB Toshiba SD card with only a few music files but it isnt recognised. The unit keeps reading "data corrupted".
    I've simply "copy" and "paste" the mp3 files from computer onto the SD card. I also tried setting up a folder and "copy" and "paste" the files likewise. Still no luck!!
    I then made an mp3 audio CD using the exact same mp3 files. This worked a treat.

    I dont realy intend to use the SD card slots for music, but I've realised that the DVD navigation is disabled if Im using the mp3 audio disc. I'll eventually connect my ipod to the headunit, but I got to remake and new docking station first.

    Any thoughts on the SD card issue?
    Cheers
    Dan
    #1
  2. RichC
    Offline

    RichC RAC 500W

    Joined:
    Apr 16, 2008
    Messages:
    180
    Likes Received:
    0
    Was the card formatted before you tried to put all of the songs on it? Sometimes if you take a card from another device and dont format it they dont like it, certain phones are a prime example.

    Failing that are the files in the right format?

    Rich
    #2
  3. Issac Hunt
    Offline

    Issac Hunt Active Member

    Joined:
    Jan 6, 2007
    Messages:
    1,162
    Likes Received:
    0
    Format to FAT32 standard.
    #3
  4. lil_coz
    Offline

    lil_coz Active Member

    Joined:
    Nov 13, 2007
    Messages:
    1,641
    Likes Received:
    19
    I found that when I copied the music folder to the SD card it didnt work. Then I realised that in the folder there were hidden files and thats what confuses the car. Copy each song individually, not in folders and it should be ok. But I'd also format the SD card to make sure theres nothing else on it.

    Coss
    #4
  5. Young un
    Offline

    Young un Member

    Joined:
    Mar 8, 2008
    Messages:
    101
    Likes Received:
    0
    Thanks, I'll only copy each file individually then to avoid "copying over" any errorenous files.

    Apologies for this next question though. I've no idea how to format the SD card. I've just deleted all files/folders that is currently stored on it - surely that isnt formatted??

    Thanks again
    #5
  6. redbutcher
    Offline

    redbutcher Member

    Joined:
    Aug 28, 2007
    Messages:
    649
    Likes Received:
    0
    You'll need to go to 'My Computer' on your PC. You should then see your SD card appear as a drive letter (i.e. D: or E: etc.)

    Right mouse click on the correct drive that is your SD card and select format.

    In the options that appear, make sure you chose to format the card as FAT32 as Issac said in an earlier post. Click OK and it should format.

    Also make sure when copying MP3s across that file names are shorter than 64 characters.

    Plenty of info on SD Cards here
    #6
  7. PetrolDave
    Offline

    PetrolDave Active Member

    Joined:
    Nov 25, 2003
    Messages:
    1,559
    Likes Received:
    82
    It's the total file path (name + folders) that needs to be less than 64 characters.
    #7
  8. redbutcher
    Offline

    redbutcher Member

    Joined:
    Aug 28, 2007
    Messages:
    649
    Likes Received:
    0
    :icon_thumright: - thanks for the clarification Dave.
    #8

Share This Page