1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S5 creaking calliper

Discussion in 'A5/S5/RS5 Forum' started by SI-W85, Jul 12, 2014.

  1. SI-W85
    Offline

    SI-W85 Well-Known Member

    Joined:
    Sep 19, 2013
    Messages:
    1,055
    Likes Received:
    228
    [Jul 12, 2014]
    I have just upgraded (i hope) to some S5 callipers and black diamond discs with some EBC red stuff pads. Anyway they were fitted to my A4 last Saturday I then drove 300 miles to the Isle of Wight and upon arrival shortly after I noticed a horrible creaking noise coming from the front drivers brake, the noise sounds to be coming from the calliper, all sliders are greased ect ect so I am wondering if anybody has experienced this noise with there brakes before. I have a short YouTube vid for you to hear. S5 creaky calliper - YouTube
    #1
  2. Ads

    Ads

    [Nov 28, 2014]

  3. SI-W85
    Offline

    SI-W85 Well-Known Member

    Joined:
    Sep 19, 2013
    Messages:
    1,055
    Likes Received:
    228
    [Jul 12, 2014]
    Also I will add it does it when stood still by pressing the pedal on and off :/ I had the calliper in bits last night and checked everything but could not find where the noise could be coming from. It's driving me mad already
    #2
  4. warren_S5
    Offline

    warren_S5 Moderator Staff Member Moderator VCDS Map User

    Joined:
    Oct 31, 2007
    Messages:
    7,219
    Likes Received:
    2,407
    [Jul 19, 2014]
    Did you copper grease the back of the pads
    #3
  5. SI-W85
    Offline

    SI-W85 Well-Known Member

    Joined:
    Sep 19, 2013
    Messages:
    1,055
    Likes Received:
    228
    [Jul 19, 2014]
    I did use copper grease even though most say not I I still do it :/ I have been told to get some ceramic grease and do the sliders.
    #4
  6. Mokeylock
    Offline

    Mokeylock New Member

    Joined:
    Jan 16, 2013
    Messages:
    25
    Likes Received:
    0
    [Jul 21, 2014]
    I had the same problem with the OEM callipers and Audi fixed it last week.
    It turned out to be corrosion in the brake pads holder
    #5
  7. SI-W85
    Offline

    SI-W85 Well-Known Member

    Joined:
    Sep 19, 2013
    Messages:
    1,055
    Likes Received:
    228
    [Jul 22, 2014]
    Interesting :/ although I have stripped them down and there doesn't seem to be any corrosion but will double check when I next get the time to take in bits again.
    #6

Share This Page