1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

s4 rough idle when cold

Discussion in 'A4/S4 forum(B5 Chassis)' started by s3sam, Jun 13, 2013.

  1. s3sam
    Offline

    s3sam Member

    Joined:
    Dec 28, 2006
    Messages:
    68
    Likes Received:
    2
    hi guys, i have a 1999 pre facelift s4 with just over 100k on the clock. it has been chipped, has a cat back miltek exhaust and a boost gauge. when i start the car for the first time in the day it idle really rough and sounds to be misfiring, when it is doing this i can feel air being pushed back out of the intake and the turbo's sound to be spooling. also the boost gauge jumps about very quickly. there are no codes in the ecu and once it has done this for about 1min or so it is perfectly fine, runs sweet and boosts really well. also, while it is doing it if i pick the revs up to about 2k its sticks there for a couple of seconds and the starts doing it again. any suggestions?
    #1
  2. mwarrey
    Offline

    mwarrey Member

    Joined:
    Dec 27, 2003
    Messages:
    280
    Likes Received:
    0
    You could try a throttle body alignment, cured mine when I had a rough idle?
    #2
  3. s3sam
    Offline

    s3sam Member

    Joined:
    Dec 28, 2006
    Messages:
    68
    Likes Received:
    2
    will give it a go, also have some silicone vacuum pipe on the way. might help with this or potential problems.
    #3
  4. Blue_Thunder
    Offline

    Blue_Thunder Active Member

    Joined:
    Feb 1, 2007
    Messages:
    1,708
    Likes Received:
    9
    What do you mean by "i can feel air being pushed back out of the intake"?
    #4

Share This Page