1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S4 Cab Roof Problems

Discussion in 'A4/A4 cabriolet/S4 forum(B6 chassis)' started by m.jolley, Jul 28, 2013.

  1. m.jolley
    Offline

    m.jolley New Member

    Joined:
    Jul 28, 2013
    Messages:
    2
    Likes Received:
    0
    Hello there,

    I've got a problem with my 55 plate S4 Cabs roof. Yesterday I decided to put the roof down for the first time in months, I operated the roof button, the windows lowered and the front of the roof unhitched from the windscreen. It proceeded to move back ever so slightly, then stopped. Now the roof light is flashing on the dash, the roof isn't secure and will not close.

    I followed the guide on youtube and manually took the roof all the way down, then put it all the way up again, hoping that it would reset the system. It still has the same problem of unhitching, then stopping part way through. Now when the car starts up, the roof light will flash for a few seconds before going off.

    Is there a possibility that there are components which could have failed after months of no use?

    Any help would be greatly appreciated.
    Last edited: Jul 28, 2013
    #1
  2. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,678
    Likes Received:
    20
    you need to get it on VCDS to see the fault codes
    it could be anything from a sensor to the pump

    did you do the manula reset more than once ?
    sometimes takes 2/3 goes
    #2
  3. VagPro
    Offline

    VagPro Member

    Joined:
    Feb 10, 2011
    Messages:
    367
    Likes Received:
    2
    Im 99% convinced its the motor, I have written a guide on resolving this...

    http://www.audi-sport.net/vb/audi-s...et-soft-top-roof-hood-motor-repair-guide.html
    #3
  4. bez101
    Offline

    bez101 Yorkshire & Humber Rep. Regional Rep

    Joined:
    Jul 8, 2008
    Messages:
    8,678
    Likes Received:
    20
    +1 for the motor
    with out checking the MVB its hard to guide you to a repair
    #4
  5. jellyjgr
    Offline

    jellyjgr New Member

    Joined:
    Apr 10, 2014
    Messages:
    2
    Likes Received:
    0
    hi there, i know this is an older post but hoping you can assist.

    Im having some soft top roof re-set problems. We initally thought it was the motor or the pump but both seem to be working. could it be that i have to do some sort of factory re-set. we have tried to manually reset the top by taking it up and down a few times. any suggestions?
    #5
  6. VagPro
    Offline

    VagPro Member

    Joined:
    Feb 10, 2011
    Messages:
    367
    Likes Received:
    2
    Hello,

    Please describe your roof problem and symptoms to me or what happens when you try and operate the roof.

    There are mentions of a "factory reset" which involves opening and closing the roof manually, in essence this does not cause the control unit to "learn and store" the new values but just ensures all the micro-switches are in the correct position, especially if one of the locks is not locked correctly. So yes make sure your storage compartment and top lock is locked correctly (unlock it and lock it again making sure to only remove the manual key when you have reached the stop position.

    Regards
    Khurrum

    P.S. its probably better to continue this topic on the Roof Repair Guide Forum as it get a significant higher number of hits !
    #6

Share This Page