1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

S3 steaming windows!!

Discussion in 'A3/S3 Forum (8L Chassis)' started by Greig300, Feb 10, 2013.

  1. Greig300

    Greig300 Member

    Joined:
    Jan 29, 2011
    Messages:
    253
    Likes Received:
    5
    On my way to work today my audi decided it didn't want Demist the windows. Getting worse and worse as i drove regardless of temperature or fan speed or direction. The whole climate control fan speed seems slow and underpowered normally one press of the windscreen Demist button clears it and is normally powerful. I have noticed over the last 6 months or so upon startup with climate control still on...outside from engine it'd make a loud screeching noise. Possible related? Belts? No idea help! Also I have no vagcom ATM maybe pollen?
     
  2. Google AdSense Guest Advertisement



    to hide this advert.
  3. dan-quattro

    dan-quattro Member

    Joined:
    Sep 12, 2008
    Messages:
    154
    Likes Received:
    1
    often get a screeching noise which last 3 seconds or so then stops, this is just afte you start the car too.
     
  4. jojo

    jojo Looking for Boost!
    Staff Member Moderator quattro Audi S3

    Joined:
    Sep 4, 2003
    Messages:
    27,326
    Likes Received:
    2,429
    S3's are sexy aren't they! :sex:
     
  5. dan-quattro

    dan-quattro Member

    Joined:
    Sep 12, 2008
    Messages:
    154
    Likes Received:
    1
    Yes they certainly are then have the cheek to demand £££'s spending on them at the drop of a hat ;)
     
  6. AR-rkon

    AR-rkon AllROOOOOOOOOAD!!!
    Staff Member Moderator Regional Rep

    Joined:
    Oct 8, 2010
    Messages:
    1,828
    Likes Received:
    125
    Daft as it sounds, check your pollen filter, mine was choked up with crud and leaves and stifled the fan. May be a cheap fix ;)

    The screech, may be the belt on the ac compressor, as the climate kicks I. The compressor on full demist.
     
  7. Greig300

    Greig300 Member

    Joined:
    Jan 29, 2011
    Messages:
    253
    Likes Received:
    5

    Thanks for the replys, changed the pollen filter seems to fixed my issue the old old was literally dripping of water.
     
  8. AR-rkon

    AR-rkon AllROOOOOOOOOAD!!!
    Staff Member Moderator Regional Rep

    Joined:
    Oct 8, 2010
    Messages:
    1,828
    Likes Received:
    125
    ;)

    Not sure if the 8l has them, but if it does, check the drain holes in the scuttle area (nearest the filter especially) and clean them out. On my A4 B5, they were full of crud and water as was my plenum area luckily I'd weather sealed my ecu box lol
     
  9. JudderMan

    JudderMan Active Member

    Joined:
    Nov 29, 2012
    Messages:
    994
    Likes Received:
    161
    Is that what the screech is? Mine does it, and has done for a few years according to the receipts I have, but couldn't work out what it was. There was a mk1 TT doing it the other day outside my house and I ran out thinking someone was stealing my car LOL. I'll check the deflection of the belt then as it sounds like it's loose...mine only happens when it's cold though not on hot starts which makes sense that it's slightly loose. I thought it was a sticky start motor solenoid.
     
  10. Benjiman46

    Benjiman46 R-Tech Terrorist

    Joined:
    Feb 6, 2012
    Messages:
    551
    Likes Received:
    24
    Mine's been p*ssing me off lately... You start it from cold, turn the climate control on, then the aircon wont come on because it's so cold... Or that's what I think it is... It's really annoying because the weather is 90% sh*t and rainy, and when you get in it all the windows steam up. REALLY annoying -_-
     
  11. TOM.S

    TOM.S Active Member

    Joined:
    Sep 27, 2010
    Messages:
    461
    Likes Received:
    66
    Mine does that lately too. I'm gonna look at the pollen filter tomorrow then.
     
  12. danger S3

    danger S3 Member

    Joined:
    Jun 28, 2010
    Messages:
    361
    Likes Received:
    13
    if the scuttle pannel along the bottom of the windscreen isnt clipped in properly then water can get in there and into the pollen filter
     
  13. s3mad_dude

    s3mad_dude Noggies ruuuule!

    Joined:
    Jan 25, 2006
    Messages:
    499
    Likes Received:
    52
    Yeah my pre-facelift did this and pissed me off too. It doesn't come on below a certain outside temperature. I must say I think they fixed it on facelift as the a/c is always on and you have to press ECON to turn it off.
     
  14. robbiemac

    robbiemac 'S' Button engaged....

    Joined:
    Nov 6, 2012
    Messages:
    733
    Likes Received:
    386
    Usually getting rid of the dead hooker in the boot helps with the de-misting problems......... so I've heard...... truck driver told me.
    Write you're complaints about this joke to Jeremy Clarkson c/o BBC, London, W12.....
     

Share This Page